{"id":23201,"date":"2023-10-30T08:37:37","date_gmt":"2023-10-30T16:37:37","guid":{"rendered":"https:\/\/www.palada.net\/index.php\/2023\/10\/30\/news-16931\/"},"modified":"2023-10-30T08:37:37","modified_gmt":"2023-10-30T16:37:37","slug":"news-16931","status":"publish","type":"post","link":"http:\/\/www.palada.net\/index.php\/2023\/10\/30\/news-16931\/","title":{"rendered":"Multiple North Korean threat actors exploiting the TeamCity CVE-2023-42793 vulnerability"},"content":{"rendered":"<p><strong>Credit to Author: Microsoft Threat Intelligence| Date: Wed, 18 Oct 2023 16:30:00 +0000<\/strong><\/p>\n<p>Since early October 2023, Microsoft has observed two North Korean nation-state threat actors \u2013 Diamond Sleet and Onyx Sleet \u2013 exploiting CVE-2023-42793, a remote-code execution vulnerability affecting multiple versions of JetBrains TeamCity server. TeamCity is a continuous integration\/continuous deployment (CI\/CD) application used by organizations for DevOps and other software development activities.<\/p>\n<p>In past operations, Diamond Sleet and other North Korean threat actors have successfully carried out software supply chain attacks by infiltrating build environments. Given this, Microsoft assesses that this activity poses a particularly high risk to organizations who are affected. <a href=\"https:\/\/blog.jetbrains.com\/teamcity\/2023\/09\/cve-2023-42793-vulnerability-post-mortem\/\">JetBrains has released an update<\/a> to address this vulnerability and has developed a mitigation for users who are unable to update to the latest software version.<\/p>\n<p>While the two threat actors are exploiting the same vulnerability, Microsoft observed Diamond Sleet and Onyx Sleet utilizing unique sets of tools and techniques following successful exploitation.<\/p>\n<p>Based on the profile of victim organizations affected by these intrusions, Microsoft assesses that the threat actors may be opportunistically compromising vulnerable servers. However, both actors have deployed malware and tools and utilized techniques that may enable persistent access to victim environments.<\/p>\n<p>As with any observed nation-state actor activity, Microsoft directly notifies customers that have been targeted or compromised and provides them with the information they need to secure their environments.<\/p>\n<h2 class=\"wp-block-heading\">Who are Diamond Sleet and Onyx Sleet?<\/h2>\n<p>Diamond Sleet (ZINC) is a North Korean nation-state threat actor that prioritizes espionage, data theft, financial gain, and network destruction. The actor typically targets media, IT services, and defense-related entities around the world. Microsoft reported on <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2021\/01\/28\/zinc-attacks-against-security-researchers\/\">Diamond Sleet\u2019s targeting of security researchers<\/a> in January 2021 and the actor\u2019s <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/09\/29\/zinc-weaponizing-open-source-software\/\">weaponizing of open-source software<\/a> in September 2022. In August 2023, Diamond Sleet conducted a software supply chain compromise of a German software provider.<\/p>\n<p>Onyx Sleet (PLUTONIUM) is a North Korean nation-state threat actor that primarily targets defense and IT services organizations in South Korea, the United States, and India. Onyx Sleet employs a robust set of tools that they have developed to establish persistent access to victim environments and remain undetected. The actor frequently exploits N-day vulnerabilities as a means of gaining initial access to targeted organizations.<\/p>\n<h2 class=\"wp-block-heading\">Diamond Sleet attack path 1: Deployment of ForestTiger backdoor<\/h2>\n<p>Following the successful compromise of TeamCity servers, Diamond Sleet utilizes PowerShell to download two payloads from legitimate infrastructure previously compromised by the threat actor. These two payloads, <em>Forest64.exe<\/em> and <em>4800-84DC-063A6A41C5C<\/em> are stored in the <em>C:ProgramData<\/em> directory.<\/p>\n<p>When launched, <em>Forest64.exe<\/em> checks for the presence of the file named <em>4800-84DC-063A6A41C5C<\/em>, then reads and decrypts the contents of that file using embedded, statically assigned key of \u2018uTYNkfKxHiZrx3KJ\u2019:<\/p>\n<p><em>c:ProgramDataForest64.exe&nbsp; uTYNkfKxHiZrx3KJ<\/em><\/p>\n<p>Interestingly, this same value is specified as a parameter when the malware is invoked, but we did not see it utilized during our analysis. The same value and configuration name was also referenced in historical activity <a href=\"https:\/\/securelist.com\/the-lazarus-group-deathnote-campaign\/109490\/\">reported by Kaspersky\u2019s Securelist<\/a> on this malware, dubbed <em>ForestTiger<\/em>.<\/p>\n<p>The decrypted content of <em>4800-84DC-063A6A41C5C<\/em> is the configuration file for the malware, which contains additional parameters, such as the infrastructure used by the backdoor for command and control (C2). Microsoft observed Diamond Sleet using infrastructure previously compromised by the actor for C2.<\/p>\n<p>Microsoft observed <em>Forest64.exe<\/em> then creating a scheduled task named <em>Windows TeamCity Settings User Interface<\/em> so it runs every time the system starts with the above referenced command parameter \u201cuTYNkfKxHiZrx3KJ\u201d. Microsoft also observed Diamond Sleet leveraging the <em>ForestTiger<\/em> backdoor to dump credentials via the LSASS memory. Microsoft Defender Antivirus detects this malware as <em>ForestTiger<\/em>.<\/p>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig1-Diamond-Sleet-ForestTiger-1024x561.webp\" alt=\"diagram\" class=\"wp-image-131911 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig1-Diamond-Sleet-ForestTiger-1024x561.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig1-Diamond-Sleet-ForestTiger-300x165.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig1-Diamond-Sleet-ForestTiger-768x421.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig1-Diamond-Sleet-ForestTiger.webp 1262w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig1-Diamond-Sleet-ForestTiger-1024x561.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 1. Diamond Sleet attack chain 1 using ForestTiger backdoor<\/em><\/figcaption><\/figure>\n<h2 class=\"wp-block-heading\">Diamond Sleet attack path 2: Deploying payloads for use in DLL search-order hijacking attacks<\/h2>\n<p>Diamond Sleet leverages PowerShell on compromised servers to download a malicious DLL from attacker infrastructure. This malicious DLL is then staged in <em>C:ProgramData<\/em> alongside a legitimate .exe file to carry out DLL search-order hijacking. Microsoft has observed these malicious DLL and legitimate EXE combinations used by the actor:<\/p>\n<figure class=\"wp-block-table table\">\n<table class=\"has-fixed-layout\">\n<thead>\n<tr>\n<th>Malicious DLL name<\/th>\n<th>Legitimate binary name<\/th>\n<\/tr>\n<\/thead>\n<tbody>\n<tr>\n<td><em>DSROLE.dll<\/em><\/td>\n<td><em>wsmprovhost.exe<\/em><\/td>\n<\/tr>\n<tr>\n<td><em>Version.dll<\/em><\/td>\n<td><em>clip.exe<\/em><\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<p><strong><em>DSROLE.dll<\/em> attack chain<\/strong><\/p>\n<p>When <em>DSROLE.dll<\/em> is loaded by <em>wsmprovhost.exe<\/em>, the DLL initiates a thread that enumerates and attempts to process files that exist in the same executing directory as the DLL. The first four bytes of candidate files are read and signify the size of the remaining buffer to read. Once the remaining data is read back, the bytes are reversed to reveal an executable payload that is staged in memory. The expected PE file should be a DLL with the specific export named \u2018StartAction\u2019. The address of this export is resolved and then launched in memory.<\/p>\n<p>While the functionality of <em>DSROLE.dll<\/em> is ultimately decided by whatever payloads it deobfuscates and launches, Microsoft has observed the DLL being used to launch <em>wksprt.<\/em>exe, which communicates with C2 domains. Microsoft Defender Antivirus detects <em>DSROLE.dll<\/em> using the family name <em>RollSling<\/em>.<\/p>\n<p><strong><em>Version.dll<\/em> attack chain<\/strong><\/p>\n<p>When loaded by <em>clip.exe<\/em>, <em>Version.dll<\/em> loads and decrypts the contents of <em>readme.md<\/em>, a file&nbsp; downloaded alongside <em>Version.dll<\/em> from attacker-compromised infrastructure. The file <em>readme.md<\/em> contains data that is used as a multibyte XOR key to decrypt position-independent code (PIC) embedded in <em>Version.dll<\/em>. This PIC loads and launches the final-stage remote access trojan (RAT).<\/p>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig2n-Composition-of-read-me-n-1-1024x150.webp\" alt=\"Screenshot of readme.md\" class=\"wp-image-131922 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig2n-Composition-of-read-me-n-1-1024x150.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig2n-Composition-of-read-me-n-1-300x44.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig2n-Composition-of-read-me-n-1-768x112.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig2n-Composition-of-read-me-n-1.webp 1300w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig2n-Composition-of-read-me-n-1-1024x150.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 2. Composition of readme.md used as multibyte XOR key by Version.dll<\/em><\/figcaption><\/figure>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig3-Application-of-XOR-1024x118.webp\" alt=\"Screenshot of XOR key \" class=\"wp-image-131913 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig3-Application-of-XOR-1024x118.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig3-Application-of-XOR-300x35.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig3-Application-of-XOR-768x89.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig3-Application-of-XOR.webp 1300w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig3-Application-of-XOR-1024x118.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 3. Application of XOR key to expose next-stage code block<\/em><\/figcaption><\/figure>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig4-Carving-out-embedded-PE-1024x150.webp\" alt=\"Screenshot of embedded PE from code block\" class=\"wp-image-131914 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig4-Carving-out-embedded-PE-1024x150.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig4-Carving-out-embedded-PE-300x44.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig4-Carving-out-embedded-PE-768x112.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig4-Carving-out-embedded-PE.webp 1300w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig4-Carving-out-embedded-PE-1024x150.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 4. Carving out embedded PE from code block<\/em><\/figcaption><\/figure>\n<p>Once loaded in memory, the second-stage executable decrypts an embedded configuration file containing several URLs used by the malware for command and control. Shortly after the malware beacons to the callback URL, Microsoft has observed a separate process <em>iexpress.exe<\/em> created and communicating with other C2 domains. Microsoft Defender Antivirus detects <em>Version.dll<\/em> using the family name <em>FeedLoad<\/em>.<\/p>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig5-Diamond-Sleet-SLL-search-order-hijacking-1024x549.webp\" alt=\"diagram\" class=\"wp-image-131915 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig5-Diamond-Sleet-SLL-search-order-hijacking-1024x549.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig5-Diamond-Sleet-SLL-search-order-hijacking-300x161.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig5-Diamond-Sleet-SLL-search-order-hijacking-768x412.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig5-Diamond-Sleet-SLL-search-order-hijacking.webp 1262w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig5-Diamond-Sleet-SLL-search-order-hijacking-1024x549.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 5. Diamond Sleet attack chain 2 using DLL search order hijacking<\/em><\/figcaption><\/figure>\n<p>After successful compromise, Microsoft observed Diamond Sleet dumping credentials via the LSASS memory.<\/p>\n<p>In some cases, Microsoft observed Diamond Sleet intrusions that utilized tools and techniques from both paths 1 and 2.<\/p>\n<h2 class=\"wp-block-heading\">Onyx Sleet attack path: User account creation, system discovery, and payload deployment<\/h2>\n<p>Following successful exploitation using the TeamCity exploit, Onyx Sleet creates a new user account on compromised systems. This account, named <em>krtbgt<\/em>, is likely intended to impersonate the legitimate Windows account name KRBTGT, the Kerberos Ticket Granting Ticket. After creating the account, the threat actor adds it to the Local Administrators Group through net use:<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> net  localgroup administrators krtbgt \/add <\/pre>\n<\/div>\n<p>The threat actor also runs several system discovery commands on compromised systems, including:<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> net localgroup 'Remote Desktop Users\u2019 net localgroup Administrators cmd.exe &quot;\/c tasklist | findstr Sec&quot; cmd.exe &quot;\/c whoami&quot; cmd.exe &quot;\/c netstat -nabp tcp&quot; cmd.exe &quot;\/c ipconfig \/all&quot; cmd.exe &quot;\/c systeminfo&quot; <\/pre>\n<\/div>\n<p>Next, the threat actor deploys a unique payload to compromised systems by downloading it from attacker-controlled infrastructure via PowerShell. Microsoft observed these file paths for the unique payload:<\/p>\n<ul>\n<li><em>C:WindowsTemptemp.exe<\/em><\/li>\n<li><em>C:WindowsADFSbginetmgr.exe<\/em><\/li>\n<\/ul>\n<p>This payload, when launched, loads and decrypts an embedded PE resource. This decrypted payload is then loaded into memory and launched directly. The inner payload is a proxy tool that helps establish a persistent connection between the compromised host and attacker-controlled infrastructure. Microsoft Defender Antivirus detects this proxy tool as <em>HazyLoad<\/em>.<\/p>\n<p>Microsoft also observed the following post-compromise tools and techniques leveraged in this attack path:<\/p>\n<ul>\n<li>Using the attacker-controlled <em>krtbgt <\/em>account to sign into the compromised device via remote desktop protocol (RDP)<\/li>\n<li>Stopping the TeamCity service, likely in an attempt to prevent access by other threat actors<\/li>\n<li>Dumping credentials via the LSASS memory<\/li>\n<li>Deploying tools to retrieve credentials and other data stored by browsers<\/li>\n<\/ul>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig6-Onys-Sleet-user-account-creation-1024x428.webp\" alt=\"diagram\" class=\"wp-image-131916 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig6-Onys-Sleet-user-account-creation-1024x428.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig6-Onys-Sleet-user-account-creation-300x125.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig6-Onys-Sleet-user-account-creation-768x321.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig6-Onys-Sleet-user-account-creation.webp 1262w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/10\/Fig6-Onys-Sleet-user-account-creation-1024x428.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 6. Onyx Sleet attack chain with user account creation<\/em><\/figcaption><\/figure>\n<h2 class=\"wp-block-heading\">Recommended mitigation actions<\/h2>\n<p>Microsoft recommends the following mitigations to reduce the impact of this threat.<\/p>\n<ul>\n<li><a href=\"https:\/\/blog.jetbrains.com\/teamcity\/2023\/09\/cve-2023-42793-vulnerability-post-mortem\/\">Apply the update or mitigations<\/a> released by JetBrains to address CVE-2023-42793.<\/li>\n<li>Use the included indicators of compromise to investigate whether they exist in your environment and assess for potential intrusion.<\/li>\n<li>Block in-bound traffic from IPs specified in the IOC table.<\/li>\n<li>Use&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/microsoft-defender-antivirus-windows\" target=\"_blank\" rel=\"noreferrer noopener\">Microsoft Defender Antivirus<\/a>&nbsp;to protect from this threat. Turn on <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/configure-block-at-first-sight-microsoft-defender-antivirus?ocid=magicti_ta_learndoc\">cloud-delivered protection<\/a>&nbsp;and automatic sample submission. These capabilities use artificial intelligence and machine learning to quickly identify and stop new and unknown threats.<\/li>\n<li>Take immediate action to address malicious activity on the impacted device. If malicious code has been launched, the attacker has likely taken complete control of the device. Immediately isolate the system and perform a reset of credentials and tokens.<\/li>\n<li>Investigate the device timeline for indications of lateral movement activities using one of the compromised accounts. Check for additional tools that attackers might have dropped to enable credential access, lateral movement, and other attack activities.<\/li>\n<li>Ensure that \u201c<a href=\"https:\/\/learn.microsoft.com\/windows\/win32\/dlls\/dynamic-link-library-security\">Safe DLL Search Mode<\/a>\u201d is set.<\/li>\n<li>Turn on the following&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction\" target=\"_blank\" rel=\"noreferrer noopener\">attack surface reduction rule<\/a>:\n<ul>\n<li>Block executable files from running unless they meet a prevalence, age, or trusted list criterion<\/li>\n<\/ul>\n<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\">Detections<\/h2>\n<h3 class=\"wp-block-heading\">Microsoft Defender Vulnerability Management<\/h3>\n<p>Microsoft Defender Vulnerability Management surfaces devices that may be affected by the CVE-2023-42793 vulnerability leveraged in these attacks.<\/p>\n<h3 class=\"wp-block-heading\">Microsoft Defender Antivirus<\/h3>\n<p>Microsoft Defender Antivirus customers should look for the following family names for activity related to these attacks:<\/p>\n<ul>\n<li>ForestTiger<\/li>\n<li>RollSling<\/li>\n<li>FeedLoad<\/li>\n<li>HazyLoad<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\">Microsoft Defender for Endpoint<\/h3>\n<p>The following Microsoft Defender for Endpoint alerts could indicate activity associated with this threat. These alerts, however, can be triggered by unrelated threat activity.<\/p>\n<ul>\n<li>Diamond Sleet Actor activity detected<\/li>\n<li>Onyx Sleet Actor activity detected<\/li>\n<li>Possible exploitation of JetBrains TeamCity vulnerability<\/li>\n<li>Suspicious behavior by cmd.exe was observed<\/li>\n<li>Suspicious DLL loaded by an application<\/li>\n<li>Suspicious PowerShell download or encoded command execution<\/li>\n<li>Possible lateral movement involving suspicious file<\/li>\n<li>A script with suspicious content was observed<\/li>\n<li>Suspicious scheduled task<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\">Advanced hunting queries<\/h2>\n<h3 class=\"wp-block-heading\">Microsoft 365 Defender<\/h3>\n<p><strong>Command and control using iexpress.exe or wksprt.exe<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> DeviceNetworkEvents | where (InitiatingProcessFileName =~ &quot;wksprt.exe&quot; and InitiatingProcessCommandLine == &quot;wksprt.exe&quot;)  or (InitiatingProcessFileName =~ &quot;iexpress.exe&quot; and InitiatingProcessCommandLine == &quot;iexpress.exe&quot;) <\/pre>\n<\/div>\n<p><strong>Search order hijack using Wsmprovhost.exe and DSROLE.dll<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> DeviceImageLoadEvents | where InitiatingProcessFileName =~ &quot;wsmprovhost.exe&quot; | where FileName =~ &quot;DSROLE.dll&quot; | where not(FolderPath has_any(&quot;system32&quot;, &quot;syswow64&quot;)) <\/pre>\n<\/div>\n<p><strong>Search order hijack using clip.exe and Version.dll<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> DeviceImageLoadEvents | where InitiatingProcessFileName =~ &quot;clip.exe&quot; | where FileName in~(&quot;version.dll&quot;) | where not(FolderPath has_any(&quot;system32&quot;, &quot;syswow64&quot;, &quot;program files&quot;, &quot;windows defender\\platform&quot;, &quot;winsxs&quot;, &quot;platform&quot;, &quot;trend micro&quot;)) <\/pre>\n<\/div>\n<h3 class=\"wp-block-heading\">Microsoft Sentinel<\/h3>\n<p>Microsoft Sentinel customers can use the TI Mapping analytics (a series of analytics all prefixed with \u2018TI map\u2019) to automatically match the malicious domain indicators mentioned in this blog post with data in their workspace. If the TI Map analytics are not currently deployed, customers can install the Threat Intelligence solution from the <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/sentinel-solutions-deploy\">Microsoft Sentinel Content Hub<\/a> to have the analytics rule deployed in their Sentinel workspace.<\/p>\n<p>Microsoft Sentinel also has a range of detection and threat hunting content that customers can use to detect the post exploitation activity detailed in this blog in addition to Microsoft 365 Defender detections list above. &nbsp;<\/p>\n<ul>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Windows%20Security%20Events\/Hunting%20Queries\/powershell_downloads.yaml\">PowerShell downloads<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Endpoint%20Threat%20Protection%20Essentials\/Analytic%20Rules\/DumpingLSASSProcessIntoaFile.yaml\">Dumping LSASS Process into a File<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/ddfa24a8657415f64b4d35ecc384ab7b8b675c7f\/Solutions\/UEBA%20Essentials\/Hunting%20Queries\/Anomalous%20Account%20Creation.yaml\">Anomalous Account Creation<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/ddfa24a8657415f64b4d35ecc384ab7b8b675c7f\/Detections\/SecurityEvent\/RDP_RareConnection.yaml#L2\">RDP Rare Connection<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/ddfa24a8657415f64b4d35ecc384ab7b8b675c7f\/Solutions\/UEBA%20Essentials\/Hunting%20Queries\/Anomalous%20RDP%20Activity.yaml\">Anomalous RDP Activity<\/a><\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\">Indicators of compromise (IOCs)<\/h2>\n<p>The list below provides IOCs observed during our investigation. We encourage our customers to investigate these indicators in their environments and implement detections and protections to identify past related activity and prevent future attacks against their systems.<\/p>\n<h3 class=\"wp-block-heading\">Diamond Sleet path 1<\/h3>\n<figure class=\"wp-block-table table\">\n<table class=\"has-fixed-layout\">\n<thead>\n<tr>\n<th>Indicator<\/th>\n<th>Type<\/th>\n<th>Description<\/th>\n<\/tr>\n<\/thead>\n<tbody>\n<tr>\n<td>C:ProgramDataForest64.exe &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<\/td>\n<td>File path<\/td>\n<td>File path of ForestTiger binary<\/td>\n<\/tr>\n<tr>\n<td>e06f29dccfe90ae80812c2357171b5c48fba189ae103d28e972067b107e58795<\/td>\n<td>SHA-256<\/td>\n<td>Hash of Forest64.exe<\/td>\n<\/tr>\n<tr>\n<td>0be1908566efb9d23a98797884f2827de040e4cedb642b60ed66e208715ed4aa<\/td>\n<td>SHA-256<\/td>\n<td>Hash of Forest64.exe<\/td>\n<\/tr>\n<tr>\n<td>C:ProgramData4800-84DC-063A6A41C5C<\/td>\n<td>File path<\/td>\n<td>ForestTiger configuration file<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/www.bandarpowder[.]com\/public\/assets\/img\/cfg.png<\/td>\n<td>URL<\/td>\n<td>Staging URL for 4800-84DC-063A6A41C5C (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxps:\/\/www.bandarpowder[.]com\/public\/assets\/img\/cfg.png<\/td>\n<td>URL<\/td>\n<td>Staging URL for 4800-84DC-063A6A41C5C (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/www.aeon-petro[.]com\/wcms\/plugins\/addition_contents\/cfg.png<\/td>\n<td>URL<\/td>\n<td>Staging URL for 4800-84DC-063A6A41C5C (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/www.bandarpowder[.]com\/public\/assets\/img\/user64.png<\/td>\n<td>URL<\/td>\n<td>Staging URL for Forest64.exe (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxps:\/\/www.bandarpowder[.]com\/public\/assets\/img\/user64.png<\/td>\n<td>URL<\/td>\n<td>Staging URL for Forest64.exe (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/www.aeon-petro[.]com\/wcms\/plugins\/addition_contents\/user64.png<\/td>\n<td>URL<\/td>\n<td>Staging URL for Forest64.exe (compromised domain)<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<h3 class=\"wp-block-heading\">Diamond Sleet path 2<\/h3>\n<figure class=\"wp-block-table table\">\n<table class=\"has-fixed-layout\">\n<thead>\n<tr>\n<th>Indicator<\/th>\n<th>Type<\/th>\n<th>Description<\/th>\n<\/tr>\n<\/thead>\n<tbody>\n<tr>\n<td>C:ProgramDataDSROLE.dll<\/td>\n<td>File path<\/td>\n<td>File path of RollSling binary &nbsp;<\/td>\n<\/tr>\n<tr>\n<td>d9add2bfdfebfa235575687de356f0cefb3e4c55964c4cb8bfdcdc58294eeaca<\/td>\n<td>SHA-256<\/td>\n<td>Hash of DSROLE.dll<\/td>\n<\/tr>\n<tr>\n<td>C:ProgramDataVersion.dll<\/td>\n<td>File path &nbsp;<\/td>\n<td>File path of FeedLoad binary.<\/td>\n<\/tr>\n<tr>\n<td>f251144f7ad0be0045034a1fc33fb896e8c32874e0b05869ff5783e14c062486<\/td>\n<td>SHA-256<\/td>\n<td>Hash of Version.dll<\/td>\n<\/tr>\n<tr>\n<td>C:ProgramDatareadme.md<\/td>\n<td>File path &nbsp;<\/td>\n<td>Used as a multibyte XOR key for FeedLoad Next Stage<\/td>\n<\/tr>\n<tr>\n<td>fa7f6ac04ec118dd807c1377599f9d369096c6d8fb1ed24ac7a6ec0e817eaab6<\/td>\n<td>SHA-256<\/td>\n<td>Hash of Readme.md<\/td>\n<\/tr>\n<tr>\n<td>C:ProgramDatawsmprovhost.exe<\/td>\n<td>File path<\/td>\n<td>Legitimate Windows binary is copied to this directory for DLL search-order hijacking<\/td>\n<\/tr>\n<tr>\n<td>C:ProgramDataclip.exe<\/td>\n<td>File path<\/td>\n<td>Legitimate Windows binary is copied to this directory for DLL search-order hijacking<\/td>\n<\/tr>\n<tr>\n<td>dersmarketim[.]com<\/td>\n<td>Domain<\/td>\n<td>C2 domain (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>olidhealth[.]com<\/td>\n<td>Domain<\/td>\n<td>C2 domain (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>galerielamy[.]com<\/td>\n<td>Domain<\/td>\n<td>C2 domain (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>3dkit[.]org<\/td>\n<td>Domain<\/td>\n<td>C2 domain (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/www.mge[.]sn\/themes\/classic\/modules\/ps_rssfeed\/feed.zip<\/td>\n<td>URL<\/td>\n<td>Staging URL for Version.dll (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/www.mge[.]sn\/themes\/classic\/modules\/ps_rssfeed\/feedmd.zip<\/td>\n<td>URL<\/td>\n<td>Staging URL for readme.md (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxps:\/\/vadtalmandir[.]org\/admin\/ckeditor\/plugins\/icontact\/about.php<\/td>\n<td>URL<\/td>\n<td>Callback URL from second-stage PE (compromised domain)<\/td>\n<\/tr>\n<tr>\n<td>hxxps:\/\/commune-fraita[.]ma\/wp-content\/plugins\/wp-contact\/contact.php<\/td>\n<td>URL<\/td>\n<td>Callback URL from second-stage PE (compromised domain)<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<h3 class=\"wp-block-heading\">Onyx Sleet path<\/h3>\n<figure class=\"wp-block-table table\">\n<table class=\"has-fixed-layout\">\n<thead>\n<tr>\n<th>Indicator<\/th>\n<th>Type<\/th>\n<th>Description<\/th>\n<\/tr>\n<\/thead>\n<tbody>\n<tr>\n<td>C:WindowsTemptemp.exe<\/td>\n<td>File path<\/td>\n<td>File path for HazyLoad binary<\/td>\n<\/tr>\n<tr>\n<td>C:WindowsADFSbginetmgr.exe<\/td>\n<td>File path<\/td>\n<td>File path for HazyLoad binary<\/td>\n<\/tr>\n<tr>\n<td>000752074544950ae9020a35ccd77de277f1cd5026b4b9559279dc3b86965eee<\/td>\n<td>SHA-256<\/td>\n<td>Hash of proxy tool loader<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/147.78.149[.]201:9090\/imgr.ico<\/td>\n<td>URL<\/td>\n<td>Staging URL for HazyLoad binary (compromised infrastructure)<\/td>\n<\/tr>\n<tr>\n<td>hxxp:\/\/162.19.71[.]175:7443\/bottom.gif<\/td>\n<td>URL<\/td>\n<td>Staging URL for HazyLoad binary (compromised infrastructure)<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<p>NOTE: These indicators should not be considered exhaustive for this observed activity.<\/p>\n<h3 class=\"wp-block-heading\">References<\/h3>\n<ul>\n<li><a href=\"https:\/\/securelist.com\/the-lazarus-group-deathnote-campaign\/109490\/\">Following the Lazarus group by tracking DeathNote campaign | Securelist<\/a><\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\">Further reading<\/h3>\n<p>For the latest security research from the Microsoft Threat Intelligence community, check out the Microsoft Threat Intelligence Blog:&nbsp;<a href=\"https:\/\/aka.ms\/threatintelblog\">https:\/\/aka.ms\/threatintelblog<\/a>.<\/p>\n<p>To get notified about new publications and to join discussions on social media, follow us on Twitter at&nbsp;<a href=\"https:\/\/twitter.com\/MsftSecIntel\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/twitter.com\/MsftSecIntel<\/a>.<\/p>\n<\/p>\n<p>The post <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/10\/18\/multiple-north-korean-threat-actors-exploiting-the-teamcity-cve-2023-42793-vulnerability\/\">Multiple North Korean threat actors exploiting the TeamCity CVE-2023-42793 vulnerability<\/a> appeared first on <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\">Microsoft Security Blog<\/a>.<\/p>\n<p><a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/10\/18\/multiple-north-korean-threat-actors-exploiting-the-teamcity-cve-2023-42793-vulnerability\/\" target=\"bwo\" >https:\/\/blogs.technet.microsoft.com\/mmpc\/feed\/<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p><strong>Credit to Author: Microsoft Threat Intelligence| Date: Wed, 18 Oct 2023 16:30:00 +0000<\/strong><\/p>\n<p> Since early October 2023, Microsoft has observed North Korean nation-state threat actors Diamond Sleet and Onyx Sleet exploiting the Jet Brains TeamCity CVE-2023-42793 remote-code execution vulnerability. Given supply chain attacks carried out by these threat actors in the past, Microsoft assesses that this activity poses a particularly high risk to organizations who are affected.<\/p>\n<p>The post <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/10\/18\/multiple-north-korean-threat-actors-exploiting-the-teamcity-cve-2023-42793-vulnerability\/\">Multiple North Korean threat actors exploiting the TeamCity CVE-2023-42793 vulnerability<\/a> appeared first on <a rel=\"nofollow\" href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\">Microsoft Security Blog<\/a>.<\/p>\n","protected":false},"author":4,"featured_media":0,"comment_status":"open","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"colormag_page_container_layout":"default_layout","colormag_page_sidebar_layout":"default_layout","footnotes":""},"categories":[10759,10378],"tags":[30380,30381,30382],"class_list":["post-23201","post","type-post","status-publish","format-standard","hentry","category-microsoft","category-security","tag-diamond-sleet-zinc","tag-sleet","tag-state-sponsored-threat-actor"],"_links":{"self":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts\/23201","targetHints":{"allow":["GET"]}}],"collection":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/users\/4"}],"replies":[{"embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/comments?post=23201"}],"version-history":[{"count":0,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts\/23201\/revisions"}],"wp:attachment":[{"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/media?parent=23201"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/categories?post=23201"},{"taxonomy":"post_tag","embeddable":true,"href":"http:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/tags?post=23201"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}