{"id":25129,"date":"2024-09-12T09:01:02","date_gmt":"2024-09-12T17:01:02","guid":{"rendered":"http:\/\/www.palada.net\/index.php\/2024\/09\/12\/news-18859\/"},"modified":"2024-09-12T09:01:02","modified_gmt":"2024-09-12T17:01:02","slug":"news-18859","status":"publish","type":"post","link":"https:\/\/www.palada.net\/index.php\/2024\/09\/12\/news-18859\/","title":{"rendered":"Peach Sandstorm deploys new custom Tickler malware in long-running intelligence gathering operations"},"content":{"rendered":"<p><strong>Credit to Author: Microsoft Threat Intelligence| Date: Wed, 28 Aug 2024 15:00:00 +0000<\/strong><\/p>\n<p>Between April and July 2024, Microsoft observed Iranian state-sponsored threat actor Peach Sandstorm deploying a new custom multi-stage backdoor, which we named Tickler. Tickler has been used in attacks against targets in the satellite, communications equipment, oil and gas, as well as federal and state government sectors in the United States and the United Arab Emirates. This activity is consistent with the threat actor\u2019s persistent intelligence gathering objectives and represents the latest evolution of their long-standing cyber operations.<\/p>\n<p>Peach Sandstorm also continued conducting <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2023\/09\/14\/peach-sandstorm-password-spray-campaigns-enable-intelligence-collection-at-high-value-targets\/\">password spray attacks<\/a> against the educational sector for infrastructure procurement and against the satellite, government, and defense sectors as primary targets for intelligence collection. In addition, Microsoft observed intelligence gathering and possible social engineering targeting organizations within the higher education, satellite, and defense sectors via the professional networking platform LinkedIn.<\/p>\n<p>Microsoft assesses that Peach Sandstorm operates on behalf of the Iranian Islamic Revolutionary Guard Corps (IRGC) based on the group\u2019s victimology and operational focus. Microsoft further assesses that Peach Sandstorm\u2019s operations are designed to facilitate intelligence collection in support of Iranian state interests.<\/p>\n<p>Microsoft tracks Peach Sandstorm campaigns and directly notifies customers who we observe have been targeted or compromised, providing them with the necessary information to help secure their environment. As part of our continuous monitoring, analysis, and reporting on the threat landscape, we are sharing our research on Peach Sandstorm\u2019s use of Tickler to raise awareness of this threat actor\u2019s evolving tradecraft and to educate organizations on how to harden their attack surfaces against this and similar activity. Microsoft published information on unrelated election interference linked to Iran in the most recent <a href=\"https:\/\/blogs.microsoft.com\/on-the-issues\/2024\/08\/08\/iran-targeting-2024-us-election\/\">Microsoft Threat Analysis Center (MTAC) report<\/a>.<\/p>\n<h2 class=\"wp-block-heading\" id=\"evolution-of-peach-sandstorm-tradecraft\">Evolution of Peach Sandstorm tradecraft<\/h2>\n<p>In past campaigns, Peach Sandstorm has been observed to use password spray attacks to gain access to targets of interest with a high level of success. The threat actor has also conducted intelligence gathering via LinkedIn, researching organizations and individuals employed in the higher education, satellite, and defense sectors.<\/p>\n<p>During the group\u2019s latest operations, Microsoft observed new tactics, techniques, and procedures (TTPs) following initial access via password spray attacks or social engineering. Between April and July 2024, Peach Sandstorm deployed a new custom multi-stage backdoor, Tickler, and leveraged Azure infrastructure hosted in fraudulent, attacker-controlled Azure subscriptions for command-and-control (C2). Microsoft continuously monitors Azure, along with all Microsoft products and services, to ensure compliance with our terms of service. Microsoft has notified affected organizations and disrupted the fraudulent Azure infrastructure and accounts associated with this activity.<\/p>\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-1024x541.webp\" alt=\"A diagram of the Peach Sandstorm attack chain that starts from initial access to the deployment of Tickler backdoor.\" class=\"wp-image-135565 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-1024x541.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-300x158.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-768x405.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-1536x811.webp 1536w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-2048x1081.webp 2048w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-1-Peach-Sandtorm-Tickler-attack-chain-1024x541.webp\"><figcaption class=\"wp-element-caption\">Figure 1. Peach Sandstorm attack chain<\/figcaption><\/figure>\n<h3 class=\"wp-block-heading\" id=\"intelligence-gathering-on-linkedin\">Intelligence gathering on LinkedIn<\/h3>\n<p>Going back to at least November 2021 and continuing through mid-2024, Microsoft observed Peach Sandstorm using multiple LinkedIn profiles masquerading as students, developers, and talent acquisition managers based in the US and Western Europe. Peach Sandstorm primarily used them to conduct intelligence gathering and possible social engineering against the higher education, satellite sectors, and related industries. The identified LinkedIn accounts were subsequently taken down. Information on LinkedIn\u2019s policies and actions against inauthentic behavior on its platform is available <a href=\"https:\/\/www.linkedin.com\/help\/linkedin\/answer\/a1425416?src=li-other&amp;veh=security.linkedin.com\">here<\/a>.<\/p>\n<h3 class=\"wp-block-heading\" id=\"password-spray-attacks-as-a-common-attack-vector\">Password spray attacks as a common attack vector<\/h3>\n<p>Since at least February 2023, Microsoft has observed Peach Sandstorm carrying out password spray activity against thousands of organizations. In password spray attacks, threat actors attempt to authenticate to many different accounts using a single password or a list of commonly used passwords. In contrast to brute force attacks, which target a single account using many passwords, password spray attacks help adversaries maximize their chances for success and minimize the likelihood of automatic account lockouts.<\/p>\n<p>Microsoft has observed that once Peach Sandstorm has verified a target account\u2019s credentials using the password spray technique, the threat actor performed subsequent sign-ins to the compromised accounts from commercial VPN infrastructure.<\/p>\n<p>In April and May 2024, Microsoft observed Peach Sandstorm conducting password spray attacks targeting organizations in the defense, space, education, and government sectors in the US and Australia. In particular, Peach Sandstorm continued to use the <em>\u201cgo-http-client\u201d<\/em> user agent that they are known to leverage in password spray campaigns. While the password spray activity appeared consistently across sectors, Microsoft observed Peach Sandstorm exclusively leveraging compromised user accounts in the education sector to procure operational infrastructure. In these cases, the threat actor accessed existing Azure subscriptions or created one using the compromised account to host their infrastructure. The attacker-controlled Azure infrastructure then served as C2 or operational hops for Peach Sandstorm operations targeting the government, defense, and space sectors. Recent <a href=\"https:\/\/aka.ms\/AzureMFABlogPost\">updates to security defaults in Azure<\/a>, such as multi-factor authentication help ensure that Azure accounts are more resistant to account compromise techniques such as those used by Peach Sandstorm.<\/p>\n<h3 class=\"wp-block-heading\" id=\"tickler-malware\">Tickler malware<\/h3>\n<p>Microsoft Threat Intelligence identified two samples of the Tickler malware, a custom multi-stage backdoor, that Peach Sandstorm deployed in compromised environments as recently as July 2024. The first sample was contained in an archive file named <em>Network Security.zip<\/em> alongside benign PDF files used as decoy documents. The archive file contained:<\/p>\n<ul class=\"wp-block-list\">\n<li><em>YAHSAT NETWORK_INFRASTRUCTURE_SECURITY_GUIDE_20240421.pdf.exe &#8211; <\/em>theTickler malware<\/li>\n<li><em>Yahsat Policy Guide- April 2024.pdf<\/em> &#8211; a benign PDF<\/li>\n<li><em>YAHSAT NETWORK_INFRASTRUCTURE_SECURITY_GUIDE_20240421.pdf<\/em> &#8211; a second benign PDF<\/li>\n<\/ul>\n<p><em>YAHSAT NETWORK_INFRASTRUCTURE_SECURITY_GUIDE_20240421.pdf.exe<\/em> is a 64-bit C\/C++ based native PE file. The sample begins with a Process Environment Block (PEB) traversal to locate the in-memory address of file <em>kernell32.dll<\/em>.<\/p>\n<p>Upon successful PEB traversal yielding the address of <em>kernell32.dll<\/em> in memory, the sample decrypts a string to LoadLibraryA and resolves its address, decrypts the string &#8220;kernel32.dll&#8221;, and loads it again using LoadLibraryA. The sample then launches the benign PDF file <em>YAHSAT NETWORK_INFRASTRUCTURE_SECURITY_GUIDE_20240421.pdf<\/em> as a decoy document.<\/p>\n<p>The sample collects the network information from the host and sends it to the C2 URI via HTTP POST request, likely as a means for the threat actor to orient themselves on the compromised network. The below network information is an example generated in a lab environment:<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-2-network-information-collected-by-tickler-after-deployment-on-target-host.webp\" alt=\"A screenshot of sample network information captured by Tickler malware.\" class=\"wp-image-135567 webp-format\" srcset=\"\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-2-network-information-collected-by-tickler-after-deployment-on-target-host.webp\"><figcaption class=\"wp-element-caption\">Figure 2. Network information collected by Tickler after deployment on target host<\/figcaption><\/figure>\n<p>We subsequently observed Peach Sandstorm iterating and improving on this initial sample. The second Tickler sample, <em>sold.dll<\/em>, is a Trojan dropper functionally identical to the previously identified sample. The malware downloads additional payloads from the C2 server, including a backdoor, a batch script to set persistence for this backdoor, and the following legitimate files:<\/p>\n<ul class=\"wp-block-list\">\n<li><em>msvcp140.dll<\/em> (SHA-256: dad53a78662707d182cdb230e999ef6effc0b259def31c196c51cc3e8c42a9b8)<\/li>\n<li><em>LoggingPlatform.dll<\/em> (SHA-256: 56ac00856b19b41bc388ecf749eb4651369e7ced0529e9bf422284070de457b6)<\/li>\n<li><em>vcruntime140.dll<\/em> (SHA-256: 22017c9b022e6f2560fee7d544a83ea9e3d85abee367f2f20b3b0448691fe2d4)<\/li>\n<li><em>Microsoft.SharePoint.NativeMessaging.exe<\/em> (SHA-256: e984d9085ae1b1b0849199d883d05efbccc92242b1546aeca8afd4b1868c54f5)<\/li>\n<\/ul>\n<p>The files <em>msvcp140.dll<\/em>, <em>LoggingPlatform.dll<\/em>, <em>vcruntime140.dll<\/em>, and <em>Microsoft.SharePoint.NativeMessaging.exe<\/em> are legitimate Windows signed binaries likely used for <a href=\"https:\/\/attack.mitre.org\/techniques\/T1574\/002\/\">DLL sideloading<\/a>.<\/p>\n<p>Additionally, we observed the sample downloading the following malicious files:<\/p>\n<ul class=\"wp-block-list\">\n<li>A batch script (SHA-256: 5df4269998ed79fbc997766303759768ce89ff1412550b35ff32e85db3c1f57b)<\/li>\n<li>A DLL file (SHA-256: fb70ff49411ce04951895977acfc06fa468e4aa504676dedeb40ba5cea76f37f)<\/li>\n<li>A DLL file (SHA-256: 711d3deccc22f5acfd3a41b8c8defb111db0f2b474febdc7f20a468f67db0350)<\/li>\n<\/ul>\n<p>The batch script adds a registry Run key for a file called <em>SharePoint.exe<\/em>, likely used to load the malicious DLL files above, thus setting up persistence:<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-3-registry-run-key-to-set-up-persistence.webp\" alt=\"Code of the registry Run key added to set up malware persistence\" class=\"wp-image-135568 webp-format\" srcset=\"\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2024\/08\/Figure-3-registry-run-key-to-set-up-persistence.webp\"><figcaption class=\"wp-element-caption\">Figure 3. Registry Run key added to set up persistence<\/figcaption><\/figure>\n<p>The two DLL files are both 64-bit C\/C++ compiled PE DLL files and appear to be functionally identical to the previously analyzed samples. As fully functional backdoors, they can run the following commands:<\/p>\n<ul class=\"wp-block-list\">\n<li>systeminfo &#8211; Gather system information<\/li>\n<li>dir &#8211; List directory<\/li>\n<li>run &#8211; Execute command<\/li>\n<li>delete &#8211; Delete file<\/li>\n<li>interval &#8211; Sleep interval<\/li>\n<li>upload &#8211; Download file from the C2<\/li>\n<li>download &#8211; Upload file to the C2<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"azure-resources-abuse\">Azure resources abuse<\/h3>\n<p>Microsoft observed Peach Sandstorm creating Azure tenants using Microsoft Outlook email accounts and creating Azure for Students subscriptions in these tenants. Additionally, the group leveraged compromised user accounts in the Azure tenants of organizations in the education sector to do the same. Within these subscriptions, Peach Sandstorm subsequently created Azure resources for use as C2 for the backdoor. Of note, we have observed multiple Iranian groups, including Smoke Sandstorm, use similar techniques in recent months. The following resources were created by Peach Sandstorm for use as Tickler C2 nodes:<\/p>\n<ul class=\"wp-block-list\">\n<li>subreviews.azurewebsites[.]net&nbsp;<\/li>\n<li>satellite2.azurewebsites[.]net&nbsp;<\/li>\n<li>nodetestservers.azurewebsites[.]net&nbsp;<\/li>\n<li>satellitegardens.azurewebsites[.]net&nbsp;<\/li>\n<li>softwareservicesupport.azurewebsites[.]net<\/li>\n<li>getservicessuports.azurewebsites[.]net<\/li>\n<li>getservicessupports.azurewebsites[.]net&nbsp;<\/li>\n<li>getsupportsservices.azurewebsites[.]net&nbsp;<\/li>\n<li>satellitespecialists.azurewebsites[.]net<\/li>\n<li>satservicesdev.azurewebsites[.]net<\/li>\n<li>servicessupports.azurewebsites[.]net<\/li>\n<li>websupportprotection.azurewebsites[.]net&nbsp;<\/li>\n<li>supportsoftwarecenter.azurewebsites[.]net<\/li>\n<li>centersoftwaresupports.azurewebsites[.]net<\/li>\n<li>softwareservicesupports.azurewebsites[.]net<\/li>\n<li>getsdervicessupoortss.azurewebsites[.]net<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"post-compromise-activity\">Post-compromise activity<\/h2>\n<p>In the past year, Peach Sandstorm has successfully compromised several organizations, primarily in the aforementioned sectors, using bespoke tooling. Once Peach Sandstorm gains access to an organization, the threat actor is known to perform lateral movement and actions on objectives using the following techniques:<\/p>\n<h3 class=\"wp-block-heading\" id=\"moving-laterally-via-server-message-block-smb\">Moving laterally via Server Message Block (SMB)<\/h3>\n<p>After compromising a European defense organization, Peach Sandstorm threat actors moved laterally via SMB. SMB lateral movement is a technique used by threat actors to move from one compromised machine to another within a network by exploiting the SMB protocol. This protocol, which is used for sharing files, printers, and other resources on a network, could be misused by attackers to propagate their access and gain control over multiple systems.<\/p>\n<h3 class=\"wp-block-heading\" id=\"downloading-and-installing-a-remote-monitoring-and-management-rmm-tool\">Downloading and installing a remote monitoring and management (RMM) tool<\/h3>\n<p>In an older intrusion against a multinational pharmaceutical company not associated with the campaign discussed in this blog, after a likely successful password spray attack, Peach Sandstorm attempted to download and install AnyDesk, a commercial RMM tool. AnyDesk has a range of capabilities that allow users to remotely access a network, persist in a compromised environment, and enable command and control. The convenience and utility of a tool like AnyDesk is amplified by the fact that it might be permitted by application controls in environments where it is used legitimately by IT support personnel or system administrators.<\/p>\n<h3 class=\"wp-block-heading\" id=\"taking-an-active-directory-ad-snapshot\">Taking an Active Directory (AD) snapshot<\/h3>\n<p>In at least one intrusion against a Middle East-based satellite operator, Peach Sandstorm actors compromised a user using a malicious ZIP file delivered via Microsoft Teams message followed by dropping AD Explorer and taking an AD snapshot. An AD snapshot is a read-only, point-in-time copy of the AD database and related files, which can be used for various legitimate administrative tasks. These snapshots can also be exploited by threat actors for malicious purposes.<\/p>\n<h2 class=\"wp-block-heading\" id=\"mitigations\">Mitigations<\/h2>\n<p>To harden networks against Peach Sandstorm activity, defenders can implement the following:<\/p>\n<ul class=\"wp-block-list\">\n<li>Reset account passwords for any accounts targeted during a password spray attack. If a targeted account had system-level permissions, <a href=\"https:\/\/learn.microsoft.com\/security\/operations\/incident-response-playbook-password-spray?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">further investigation<\/a> may be warranted.&nbsp;<\/li>\n<li><a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/enterprise-users\/users-revoke-access?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Revoke session cookies<\/a>\u202fin addition to resetting passwords.&nbsp;\n<ul>\n<li>Revoke any MFA setting changes made by the attacker on any compromised users\u2019 accounts.&nbsp;<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li>Require re-challenging MFA for MFA updates as the default.&nbsp;<\/li>\n<\/ul>\n<\/li>\n<li>Implement the\u202f<a href=\"https:\/\/learn.microsoft.com\/security\/benchmark\/azure\/?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Azure Security Benchmark<\/a>\u202fand general\u202f<a href=\"https:\/\/learn.microsoft.com\/azure\/security\/fundamentals\/identity-management-best-practices?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">best practices for securing identity infrastructure<\/a>, including:&nbsp;&nbsp;\n<ul>\n<li>Create <a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/conditional-access\/overview?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">conditional access<\/a> policies to allow or disallow access to the environment based on defined criteria.&nbsp;<\/li>\n<\/ul>\n<ul>\n<li>Block <a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/active-directory-conditional-access-no-modern-authentication?ocid=magicti_ta_learndoc\">legacy authentication with Microsoft Entra by using Conditional Access<\/a>. Legacy authentication protocols don\u2019t have the ability to enforce multifactor authentication (MFA), so blocking such authentication methods will help prevent password spray attackers from taking advantage of the lack of MFA on those protocols.&nbsp;<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li>Enable <a href=\"https:\/\/learn.microsoft.com\/windows-server\/identity\/ad-fs\/operations\/configure-ad-fs-extranet-soft-lockout-protection?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">AD FS web application proxy extranet lockout<\/a> to protect users from potential password brute force compromise.&nbsp;<\/li>\n<\/ul>\n<\/li>\n<li>Secure accounts with credential hygiene:&nbsp;\n<ul>\n<li>Practice the&nbsp;<a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/roles\/delegate-by-task?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">principle of least privilege<\/a> and audit privileged account activity in your Microsoft Entra environments to help slow and stop attackers.&nbsp;&nbsp;<\/li>\n<\/ul>\n<ul>\n<li>Deploy <a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/hybrid\/connect\/how-to-connect-health-adfs?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Microsoft Entra Connect Health<\/a> for Active Directory Federation Services (AD FS). This captures failed attempts as well as IP addresses recorded in AD FS logs for bad requests in the <em>Risky IP report<\/em>.&nbsp;<\/li>\n<\/ul>\n<ul>\n<li>Use <a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/authentication\/concept-password-ban-bad?ocid=magicti_ta_learndoc\">Microsoft Entra password protection<\/a> to help detect and block known weak passwords and their variants.&nbsp;<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li><a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/identity-protection\/howto-identity-protection-configure-risk-policies?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Turn on identity protection<\/a> in Microsoft Entra to monitor for identity-based risks and create policies for risky sign ins.&nbsp;<\/li>\n<\/ul>\n<\/li>\n<li>Comply with the <a href=\"https:\/\/aka.ms\/azuremfablogpost\">recent MFA enforcement policy<\/a> requiring all Azure accounts to utilize MFA. Keep MFA always-on for privileged accounts and apply risk-based MFA for normal accounts.\n<ul class=\"wp-block-list\">\n<li>Consider transitioning to a passwordless primary authentication method, such as <a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/authentication\/tutorial-enable-azure-mfa?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Azure MFA<\/a>, certificates, or <a href=\"https:\/\/learn.microsoft.com\/windows\/security\/identity-protection\/hello-for-business\/hello-overview?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Windows Hello for Business<\/a>.&nbsp;<\/li>\n<\/ul>\n<\/li>\n<li>Secure remote desktop protocol (RDP) or Windows Virtual Desktop endpoints with MFA to harden against password spray or brute force attacks.<\/li>\n<\/ul>\n<p>To protect against password spray attacks, implement the following mitigations:<\/p>\n<ul class=\"wp-block-list\">\n<li>Eliminate&nbsp;<a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/authentication\/concept-password-ban-bad?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">insecure passwords<\/a>.<\/li>\n<li>Educate users&nbsp;<a href=\"https:\/\/support.microsoft.com\/account-billing\/view-your-work-or-school-account-sign-in-activity-from-my-sign-ins-9e7d108c-8e3f-42aa-ac3a-bca892898972?ocid=magicti_ta_support\" target=\"_blank\" rel=\"noreferrer noopener\">to&nbsp;review sign-in activity<\/a>&nbsp;and mark suspicious sign-in attempts as \u201cThis wasn\u2019t me\u201d.<\/li>\n<li>Reset account passwords for any accounts targeted during a password spray attack. If a targeted account had system-level permissions,&nbsp;<a href=\"https:\/\/learn.microsoft.com\/security\/operations\/incident-response-playbook-password-spray?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">further investigation<\/a>&nbsp;may be warranted.<\/li>\n<li>Detect, investigate, and remediate identity-based attacks using solutions like&nbsp;<a href=\"https:\/\/learn.microsoft.com\/entra\/id-protection\/overview-identity-protection?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Microsoft Entra ID Protection<\/a>.<\/li>\n<li>Investigate compromised accounts using&nbsp;<a href=\"https:\/\/learn.microsoft.com\/purview\/audit-log-investigate-accounts?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Microsoft Purview Audit (Premium)<\/a>.<\/li>\n<li><a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/authentication\/concept-password-ban-bad-on-premises?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Enforce on-premises Microsoft Entra Password Protection<\/a>&nbsp;for Microsoft Active Directory Domain Services.<\/li>\n<li><a href=\"https:\/\/learn.microsoft.com\/entra\/identity\/authentication\/tutorial-risk-based-sspr-mfa?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Use risk detections<\/a>&nbsp;for user sign-ins to trigger multifactor authentication or password changes.<\/li>\n<li>Investigate any possible password spray activity using the&nbsp;<a href=\"https:\/\/learn.microsoft.com\/security\/operations\/incident-response-playbook-password-spray?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">password spray investigation playbook<\/a>.<\/li>\n<\/ul>\n<p>Strengthen endpoints against attacks by following these steps:<\/p>\n<ul class=\"wp-block-list\">\n<li>Turn on <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/configure-block-at-first-sight-microsoft-defender-antivirus\">cloud-delivered protection<\/a> in Microsoft Defender Antivirus or the equivalent for your antivirus product to help cover rapidly evolving attacker tools and techniques.&nbsp;<\/li>\n<li>Enable <a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/configure-real-time-protection-microsoft-defender-antivirus\" target=\"_blank\" rel=\"noreferrer noopener\">real-time protection<\/a> in Microsoft Defender Antivirus or the equivalent for your antivirus product.&nbsp;<\/li>\n<li><a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus\" target=\"_blank\" rel=\"noreferrer noopener\">Detect and block<\/a> potentially unwanted applications through Microsoft Defender for Endpoint.&nbsp;<\/li>\n<li><a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/edr-in-block-mode?ocid=magicti_ta_learndoc\">Run endpoint detection and response (EDR) in block mode<\/a> so that Microsoft Defender for Endpoint can help block malicious artifacts, even when your non-Microsoft antivirus does not detect the threat, or when Microsoft Defender Antivirus is running in passive mode. EDR in block mode works behind the scenes to help remediate malicious artifacts that are detected post-compromise.&nbsp;<\/li>\n<li>Turn on <a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction?view=o365-worldwide\">attack surface reduction rules<\/a> to help prevent common attack techniques:&nbsp;&nbsp;\n<ul>\n<li><a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction#block-executable-files-from-running-unless-they-meet-a-prevalence-age-or-trusted-list-criterion\" target=\"_blank\" rel=\"noreferrer noopener\">Block executable files from running unless they meet a prevalence, age, or trusted list criterion<\/a>&nbsp;&nbsp;<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li><a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction#block-execution-of-potentially-obfuscated-scripts\" target=\"_blank\" rel=\"noreferrer noopener\">Block execution of potentially obfuscated scripts<\/a>&nbsp;<\/li>\n<\/ul>\n<\/li>\n<li>Implement <a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/anomaly-detection-policy?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">anomaly detection<\/a> policies in Microsoft Defender for Cloud Apps.&nbsp;<\/li>\n<li>Enable protections in Microsoft Defender for Endpoint to help safeguard against malicious sites and internet-based threats.&nbsp;\n<ul>\n<li><a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/network-protection?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Network protection<\/a>&nbsp;<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li><a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/web-protection-overview?ocid=magicti_ta_learndoc\" target=\"_blank\" rel=\"noreferrer noopener\">Web protection<\/a>&nbsp;<\/li>\n<\/ul>\n<\/li>\n<li>Enable <a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/prevent-changes-to-security-settings-with-tamper-protection\">tamper protection<\/a> within Microsoft Defender for Endpoint to help prevent threat actors from disabling or changing security features, such as virus and threat protection.<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"microsoft-defender-xdr-detections\">Microsoft Defender XDR detections<\/h2>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-antivirus\">Microsoft Defender Antivirus<\/h3>\n<p>Microsoft Defender Antivirus detects components of this threat as the following malware:<\/p>\n<ul class=\"wp-block-list\">\n<li>TrojanDownloader:Win64\/Tickler<\/li>\n<li>Backdoor:Win64\/Tickler<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-endpoint\">Microsoft Defender for Endpoint<\/h3>\n<p>The following Microsoft Defender for Endpoint alerts can indicate associated threat activity:<\/p>\n<ul class=\"wp-block-list\">\n<li>Peach Sandstorm actor activity detected<\/li>\n<\/ul>\n<p>The following alerts might also indicate threat activity related to this threat. Note, however, that these alerts can be also triggered by unrelated threat activity.<\/p>\n<ul class=\"wp-block-list\">\n<li>Password spraying<\/li>\n<li>Unfamiliar Sign-in properties<\/li>\n<li>An executable file loaded an unexpected DLL file<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-identity\">Microsoft Defender for Identity<\/h3>\n<p>The following Microsoft Defender for Identity alerts can indicate activity related to this threat. Note, however, that these alerts can be also triggered by unrelated threat activity.<\/p>\n<ul class=\"wp-block-list\">\n<li>Atypical travel<\/li>\n<li>Suspicious behavior: Impossible travel activity<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-cloud-apps\">Microsoft Defender for Cloud Apps<\/h3>\n<p>The following Microsoft Defender for Cloud Apps alerts can indicate activity related to this threat. Note, however, that these alerts can be also triggered by unrelated threat activity.<\/p>\n<ul class=\"wp-block-list\">\n<li>Activity from a Tor IP address<\/li>\n<li>Suspicious Administrative Activity<\/li>\n<li>Impossible travel activity<\/li>\n<li>Multiple failed login attempts<\/li>\n<li>Activity from an anonymous proxy<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"threat-intelligence-reports\">Threat intelligence reports<\/h2>\n<p>Microsoft Defender Threat Intelligence customers can use the following reports in Microsoft products to get the most up-to-date information about the threat actor, malicious activity, and techniques discussed in this blog. These reports provide the intelligence, protection information, and recommended actions to help prevent, mitigate, or respond to associated threats found in customer environments.<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-threat-intelligence\">Microsoft Defender Threat Intelligence<\/h3>\n<ul class=\"wp-block-list\">\n<li><a href=\"https:\/\/security.microsoft.com\/intel-explorer\/articles\/9782a9ef\">Abuse of remote monitoring and management tools<\/a><\/li>\n<li><a href=\"https:\/\/security.microsoft.com\/intel-explorer\/articles\/91be20e8\">DLL sideloading and DLL search order hijacking<\/a><\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"hunting-queries\">Hunting queries<\/h2>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-xdr\">Microsoft Defender XDR<\/h3>\n<p>Microsoft Defender XDR customers can run the following query to find related activity in their networks:<\/p>\n<h4 class=\"wp-block-heading\" id=\"failed-logon-activity\">Failed logon activity<\/h4>\n<p>The following query identifies failed attempts to sign-in from multiple sources that originate from a single ISP. Attackers distribute attacks from multiple IP addresses across a single service provider to evade detection.&nbsp;<a href=\"https:\/\/security.microsoft.com\/v2\/advanced-hunting?query=H4sIAAAAAAAAA42R22rCQBCG_-tC3yF4pdALK3qpIKWFQMGCeYGYFI00aUiiYunD--3EE7jFMgzszsx_mN1QqT5VqFFG7vWuby3JQq_aHju1HvWgXwXaaUWtIgNFIHJONRMxp5LahIwN39WQ2Z4XOVViek4lQrO06pgI1Lly8AZXpi-6KXUfU4Z6wWzDzTlwG3SNP6G6MfczLbSm7zRDmC6eaiZyIoYt089xK3dbcm70cuYIzFt6xXpf5elPtgqXPka3eQLi9Da3HKE-0E2Jyl6-9vLcTvWYWZhqqDld_3_6N5-YwrP6xP9x7Y4tdnQX59urxQ5AHwCc_IjjpAIAAA&amp;timeRangeId=SetInQuery\" target=\"_blank\" rel=\"noreferrer noopener\">Run query<\/a>&nbsp;<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> IdentityLogonEvents | where Timestamp &gt; ago(4h) | where ActionType == &quot;LogonFailed&quot; | where isnotempty(AccountObjectId) | summarize TargetCount = dcount(AccountObjectId), TargetCountry = dcount(Location), TargetIPAddress = dcount(IPAddress) by ISP | where TargetCount &gt;= 100 | where TargetCountry &gt;= 5 | where TargetIPAddress &gt;= 25 <\/pre>\n<\/div>\n<h4 class=\"wp-block-heading\" id=\"connectivity-to-c2s\">Connectivity to C2s<\/h4>\n<p>The following queries identifies connectivity to Peach Sandstorm created Azure App Service apps for command and control. <a href=\"https:\/\/security.microsoft.com\/v2\/advanced-hunting?query=H4sIAFSIsmYAA81YTW_TQBCdK_4VUU6JVHqAI-KAkgoiQSVogQNCVeI4acCxrTglBPHjeft23fjbu23aIiuOMzv79s2bmfW2oQSylZ7MJZa1TGUlkbzHPaX1NUf2sE0xuhJfBvJN-hi9kZlsMPcXrIHsYDmFzx_YN_wdYDzF2BZPaiziOn05AaInz4gx5WiIS_u9sMbQCBE4z2kLyDfF9waM1P0YfJawbLhC5ICXocWygGVHjOCWm9IwoH4Jrhi2rSPykr_LeBpR47lybUO8L2YRo7yGq6blDKXADoC1wkhoqvZuqGVmc9a2K9IxFcw88hgJ7jFn-Liv8BxZofYKLIusinXqs9q3jMSeb78wr1r7d9HhuwzlFbBvYNGReth9PMSirzG78oz9HhH3MPYXn51ck02A549AUc97ucQnoe0aLFK5wj2CbVC7Aw7hp1j35Jw7oP28Ihedtx8mbz2wWBHtLbkrZrqy59yPxjlEvQdX-Su_C_gpFZX2l_CfoQcCM6Nfo08frIbMV17HidnhtszBPreWu7Yq30tTccfUSfkq_RMLfQ4cujWyi71et7F5-ynkc663Y638tNTtE-5r082fYQsfWbPq-jY1ZROzq14TzFvguRhXIL_JLYIKWbe_wfPc7Ckp75pZwqwryxWUSLlbDBrnDBnpiF6R0U31XpFVO3b37HKe1oj-OaNKmN-2qOz4NddWs1puu143h9MH2hm7qteHZcraTFlRzdm20_IQx_BefZDVcn0PfJEPJS7Zm6258vN9qmPUu1R6O7u9Um3m65irniPmMuYb2KfemUqua7Yh2XSKTRTuMdjtzs2qu3WTq75PcdKo9tXDKG_TZU3dUt9bX-UlvCe4LqBOjDNAc3Z9MHgHn9ThpJJlUc1VsS4M2ua_yVQ-qpNapjaqV3Ws1_vM8AnN6aH-LZ5XXfsVI3nMd0Z1_W41mqKs10T7jPi3qG99EnyK05_tia8tIq2BRx6x-U-J6oYZ2LfVc4-eqmo9-Qea6aTAgBIAAA&amp;timeRangeId=week\">Run query<\/a><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> let domainList = dynamic(&#x5B;&quot;subreviews.azurewebsites.net&quot;,      &quot;satellite2.azurewebsites.net&quot;,     &quot;nodetestservers.azurewebsites.net&quot;,      &quot;satellitegardens.azurewebsites.net&quot;,     &quot;softwareservicesupport.azurewebsites.net&quot;,     &quot;getservicessuports.azurewebsites.net&quot;,     &quot;getservicessupports.azurewebsites.net&quot;,     &quot;getsupportsservices.azurewebsites.net&quot;,     &quot;satellitespecialists.azurewebsites.net&quot;,     &quot;satservicesdev.azurewebsites.net&quot;,     &quot;servicessupports.azurewebsites.net&quot;,     &quot;websupportprotection.azurewebsites.net &quot;,     &quot;supportsoftwarecenter.azurewebsites.net&quot;,     &quot;centersoftwaresupports.azurewebsites.net&quot;     &quot;softwareservicesupports.azurewebsites.net&quot;,     &quot;getsdervicessupoortss.azurewebsites.net&quot;]);union (     DnsEvents     | where QueryType has_any(domainList) or Name has_any(domainList)     | project TimeGenerated, Domain = QueryType, SourceTable = &quot;DnsEvents&quot; ), (     IdentityQueryEvents     | where QueryTarget has_any(domainList)     | project Timestamp, Domain = QueryTarget, SourceTable = &quot;IdentityQueryEvents&quot; ), (     DeviceNetworkEvents     | where RemoteUrl has_any(domainList)     | project Timestamp, Domain = RemoteUrl, SourceTable = &quot;DeviceNetworkEvents&quot; ), (     DeviceNetworkInfo     | extend DnsAddresses = parse_json(DnsAddresses), ConnectedNetworks = parse_json(ConnectedNetworks)     | mv-expand DnsAddresses, ConnectedNetworks     | where DnsAddresses has_any(domainList) or ConnectedNetworks.Name has_any(domainList)     | project Timestamp, Domain = coalesce(DnsAddresses, ConnectedNetworks.Name), SourceTable = &quot;DeviceNetworkInfo&quot; ), (     VMConnection     | extend RemoteDnsQuestions = parse_json(RemoteDnsQuestions), RemoteDnsCanonicalNames = parse_json(RemoteDnsCanonicalNames)     | mv-expand RemoteDnsQuestions, RemoteDnsCanonicalNames     | where RemoteDnsQuestions has_any(domainList) or RemoteDnsCanonicalNames has_any(domainList)     | project TimeGenerated, Domain = coalesce(RemoteDnsQuestions, RemoteDnsCanonicalNames), SourceTable = &quot;VMConnection&quot; ), (     W3CIISLog     | where csHost has_any(domainList) or csReferer has_any(domainList)     | project TimeGenerated, Domain = coalesce(csHost, csReferer), SourceTable = &quot;W3CIISLog&quot; ), (     EmailUrlInfo     | where UrlDomain has_any(domainList)     | project Timestamp, Domain = UrlDomain, SourceTable = &quot;EmailUrlInfo&quot; ), (     UrlClickEvents     | where Url has_any(domainList)     | project Timestamp, Domain = Url, SourceTable = &quot;UrlClickEvents&quot; ) | order by TimeGenerated desc <\/pre>\n<\/div>\n<h4 class=\"wp-block-heading\" id=\"malicious-file-activity\">Malicious file activity<\/h4>\n<p>The following query will surface events involving malicious files related to this activity. <a href=\"https:\/\/security.microsoft.com\/v2\/advanced-hunting?query=H4sIAMaksmYAA92TS2sUQRSF77p_RdMrB7Lod_UgLoQYIrgQzE5c9FNHkkzITJSAP97vnu7REBKD26Horqpb554691TVpY22t9gm29gl43NrbWffGO2IvuEb7N6uiV6B6O2VfbbEgmW0wQq-kai3nDZZBbKn97XWSlCdNUQaISdm2ZLbWco8py_hKxmPjAewQfFU-TWZE_-wZBTskKLgBGWJ-IJ4JrBr7ZfBMBLzecWsUb8GFxZtPas1_YF_pG9plbJ8r1pqBykqiXZadd5WqxM6XOVBRwXWFeSsrdUa5QdGrrFXLCi3JjdV_qyqlj-jdHodmarIWa20s1c8acdcqEpOFORk8jswO-jwc-hgzIj2crKUAy34TieUSZP7k8KTLyeRq-pK1deqwVFee6-TKTQKOtdWej2_IW9Q3-sWlH90BDnnetfS3IMrVY-77xUVqqcQ41yX35NSbnVyc9QpZdqvVB2THM2kNJVDqcY5nJXcHVh17xP7Yit7bZHdcXc3tuUfcXcj1M3tFP4futGjnS13_x2REeSeu_8X-Yvvp17ELV9sn3gjb7V7zWwDPob5qfezesRyA8PWvssrf3MX5FwJudf7upF7Z4-Y5lf4cNcTzbfUdiv9FyA75czY5MXqEpSt4Hnek-P04v88eI-O1r4y-sAOLbfrOF35d50v-_RRqnvp3B2pR8_XOPsTSdsW1KAaY7jun1QXC7GDK7LfANqZY34HAAA&amp;timeRangeId=week\">Run query<\/a><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\"> let fileHashes = dynamic(&#x5B;&quot;711d3deccc22f5acfd3a41b8c8defb111db0f2b474febdc7f20a468f67db0350&quot;, &quot;fb70ff49411ce04951895977acfc06fa468e4aa504676dedeb40ba5cea76f37f&quot;, &quot;5df4269998ed79fbc997766303759768ce89ff1412550b35ff32e85db3c1f57b&quot;, &quot;ccb617cc7418a3b22179e00d21db26754666979b4c4f34c7fda8c0082d08cec4&quot;, &quot;7eb2e9e8cd450fc353323fd2e8b84fbbdfe061a8441fd71750250752c577d198&quot;]); union (     DeviceFileEvents     | where SHA256 in (fileHashes)     | project Timestamp, FileHash = SHA256, SourceTable = &quot;DeviceFileEvents&quot; ), (     DeviceEvents     | where SHA256 in (fileHashes)     | project Timestamp, FileHash = SHA256, SourceTable = &quot;DeviceEvents&quot; ), (     DeviceImageLoadEvents     | where SHA256 in (fileHashes)     | project Timestamp, FileHash = SHA256, SourceTable = &quot;DeviceImageLoadEvents&quot; ), (     DeviceProcessEvents     | where SHA256 in (fileHashes)     | project Timestamp, FileHash = SHA256, SourceTable = &quot;DeviceProcessEvents&quot; ) | order by Timestamp desc <\/pre>\n<\/div>\n<h3 class=\"wp-block-heading\" id=\"microsoft-sentinel\">Microsoft Sentinel<\/h3>\n<p>Microsoft Sentinel customers can use the TI Mapping analytics (a series of analytics all prefixed with \u2018TI map\u2019) to automatically match the malicious domain indicators mentioned in this blog post with data in their workspace. If the TI Map analytics are not currently deployed, customers can install the Threat Intelligence solution from the <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/sentinel-solutions-deploy\">Microsoft Sentinel Content Hub<\/a> to have the analytics rule deployed in their Sentinel workspace.<\/p>\n<ul class=\"wp-block-list\">\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Microsoft%20Entra%20ID\/Analytic%20Rules\/SigninPasswordSpray.yaml\">Signin Password Spray<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Business%20Email%20Compromise%20-%20Financial%20Fraud\/Hunting%20Queries\/new_locations_azuread_signin.yaml\">New Location Azure AD Sign Ins<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Hunting%20Queries\/Microsoft%20365%20Defender\/Discovery\/Enumeration%20of%20users%20%26%20groups%20for%20lateral%20movement.yaml\">Enumeration of users &amp; groups for lateral movement<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Hunting%20Queries\/Microsoft%20365%20Defender\/Discovery\/SMB%20shares%20discovery.yaml\">SMB shares Discovery<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Network%20Session%20Essentials\/Analytic%20Rules\/Anomaly%20in%20SMB%20Traffic(ASIM%20Network%20Session%20schema).yaml\">Anomaly in SMB Traffic<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Hunting%20Queries\/Microsoft%20365%20Defender\/RemoteManagementMonitoring\/rmm_AnyDesk_netconn.yaml\">AnyDesk Net Connection<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Hunting%20Queries\/Microsoft%20365%20Defender\/RemoteManagementMonitoring\/rmm_AnyDesk_filesig.yaml\">AnyDesk &#8211; File Signature<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Hunting%20Queries\/Microsoft%20365%20Defender\/RemoteManagementMonitoring\/rmm_AnyDesk_createproc.yaml\">AnyDesk &#8211; Create Process<\/a><\/li>\n<li><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Alsid%20For%20AD\/Analytic%20Rules\/DCSync.yaml\">DCSync Attack Detection<\/a><\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"indicators-of-compromise\">Indicators of compromise<\/h2>\n<h3 class=\"wp-block-heading\" id=\"domains\">Domains<\/h3>\n<ul class=\"wp-block-list\">\n<li>subreviews.azurewebsites[.]net&nbsp;<\/li>\n<li>satellite2.azurewebsites[.]net&nbsp;<\/li>\n<li>nodetestservers.azurewebsites[.]net&nbsp;<\/li>\n<li>satellitegardens.azurewebsites[.]net&nbsp;<\/li>\n<li>softwareservicesupport.azurewebsites[.]net<\/li>\n<li>getservicessuports.azurewebsites[.]net<\/li>\n<li>getservicessupports.azurewebsites[.]net&nbsp;<\/li>\n<li>getsupportsservices.azurewebsites[.]net&nbsp;<\/li>\n<li>satellitespecialists.azurewebsites[.]net<\/li>\n<li>satservicesdev.azurewebsites[.]net<\/li>\n<li>servicessupports.azurewebsites[.]net<\/li>\n<li>websupportprotection.azurewebsites[.]net&nbsp;<\/li>\n<li>supportsoftwarecenter.azurewebsites[.]net<\/li>\n<li>centersoftwaresupports.azurewebsites[.]net<\/li>\n<li>softwareservicesupports.azurewebsites[.]net<\/li>\n<li>getsdervicessupoortss.azurewebsites[.]net<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"tickler-samples-and-related-indicators\">Tickler samples and related indicators<\/h3>\n<ul class=\"wp-block-list\">\n<li><em>YAHSAT NETWORK_INFRASTRUCTURE_SECURITY_GUIDE_20240421.pdf.exe<\/em> (SHA-256:&nbsp; 7eb2e9e8cd450fc353323fd2e8b84fbbdfe061a8441fd71750250752c577d198)<\/li>\n<li><em>Sold.dll<\/em> (SHA-256: ccb617cc7418a3b22179e00d21db26754666979b4c4f34c7fda8c0082d08cec4)<\/li>\n<li>Batch script (SHA-256: 5df4269998ed79fbc997766303759768ce89ff1412550b35ff32e85db3c1f57b)<\/li>\n<li>Malicious DLL (SHA-256: fb70ff49411ce04951895977acfc06fa468e4aa504676dedeb40ba5cea76f37f)<\/li>\n<li>Malicious DLL (SHA-256: 711d3deccc22f5acfd3a41b8c8defb111db0f2b474febdc7f20a468f67db0350)<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"learn-more\">Learn more<\/h2>\n<p>For the latest security research from the Microsoft Threat Intelligence community, check out the Microsoft Threat Intelligence Blog:&nbsp;<a href=\"https:\/\/aka.ms\/threatintelblog\">https:\/\/aka.ms\/threatintelblog<\/a>.<\/p>\n<p>To get notified about new publications and to join discussions on social media, follow us on LinkedIn at <a href=\"https:\/\/www.linkedin.com\/showcase\/microsoft-threat-intelligence\">https:\/\/www.linkedin.com\/showcase\/microsoft-threat-intelligence<\/a> and on X (formerly Twitter) at&nbsp;<a href=\"https:\/\/twitter.com\/MsftSecIntel\">https:\/\/twitter.com\/MsftSecIntel<\/a>.<\/p>\n<p>To hear stories and insights from the Microsoft Threat Intelligence community about the ever-evolving threat landscape, listen to the Microsoft Threat Intelligence podcast: <a href=\"https:\/\/thecyberwire.com\/podcasts\/microsoft-threat-intelligence\">https:\/\/thecyberwire.com\/podcasts\/microsoft-threat-intelligence<\/a>.<\/p>\n<p>The post <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2024\/08\/28\/peach-sandstorm-deploys-new-custom-tickler-malware-in-long-running-intelligence-gathering-operations\/\">Peach Sandstorm deploys new custom Tickler malware in long-running intelligence gathering operations<\/a> appeared first on <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\">Microsoft Security Blog<\/a>.<\/p>\n<p><a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2024\/08\/28\/peach-sandstorm-deploys-new-custom-tickler-malware-in-long-running-intelligence-gathering-operations\/\" target=\"bwo\" >https:\/\/blogs.technet.microsoft.com\/mmpc\/feed\/<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p><strong>Credit to Author: Microsoft Threat Intelligence| Date: Wed, 28 Aug 2024 15:00:00 +0000<\/strong><\/p>\n<p>Between April and July 2024, Microsoft observed Iranian state-sponsored threat actor Peach Sandstorm deploying a new custom multi-stage backdoor, which we named Tickler. Tickler has been used in attacks against targets in the satellite, communications equipment, oil and gas, as well as federal and state government sectors in the United States and the United Arab [&#8230;]<\/p>\n<p>The post <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2024\/08\/28\/peach-sandstorm-deploys-new-custom-tickler-malware-in-long-running-intelligence-gathering-operations\/\">Peach Sandstorm deploys new custom Tickler malware in long-running intelligence gathering operations<\/a> appeared first on <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\">Microsoft Security Blog<\/a>.<\/p>\n","protected":false},"author":4,"featured_media":0,"comment_status":"open","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"colormag_page_container_layout":"default_layout","colormag_page_sidebar_layout":"default_layout","footnotes":""},"categories":[10759,10378],"tags":[10408,30382],"class_list":["post-25129","post","type-post","status-publish","format-standard","hentry","category-microsoft","category-security","tag-sandstorm","tag-state-sponsored-threat-actor"],"_links":{"self":[{"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts\/25129","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/users\/4"}],"replies":[{"embeddable":true,"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/comments?post=25129"}],"version-history":[{"count":0,"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/posts\/25129\/revisions"}],"wp:attachment":[{"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/media?parent=25129"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/categories?post=25129"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.palada.net\/index.php\/wp-json\/wp\/v2\/tags?post=25129"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}